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COURSE INTRODUCTION 

 

In today's digital era, proficiency in office productivity tools and web 

technologies is essential for both personal and professional tasks. This 

course provides a comprehensive introduction to word processing, 

spreadsheets, presentations, HTML basics, and web designing, 

covering fundamental concepts and practical applications. By the end 

of the course, learners will be equipped with the necessary skills to 

create documents, manage data, design presentations, and build basic 

web pages. 

Module 1: Word Processing 

This Module introduces word processing tools, focusing 

on document creation, formatting, and automation. 

Students will learn to efficiently manage documents, apply 

styles, and use advanced editing features. 

Module 2: Spreadsheets 

A well-structured spreadsheet is essential for data 

organization and analysis. This Module introduces 

spreadsheet applications, basic formatting, formulas, and 

data manipulation techniques. 

Module 3: Presentations 

This Module covers the creation and customization of 

professional presentations, including slide layouts, 

animations, and media integration. 

Module 4: HTML Basics 

Web development starts with HTML, the foundation of 

web pages. This Module introduces basic HTML elements, 

attributes, and styling techniques. 

Module 5: Web Designing 

The evolution of digital content has led to the need for 

structured web design. This Module focuses on website 

creation using web design tools, managing site settings, 

and publishing content online. 

 

By the end of this course, Learners will gain proficiency in 

creating and managing documents, analyzing data with 

spreadsheets, and designing professional presentations. 
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Notes They will also acquire fundamental web development 

skills using HTML and be able to design and publish user-

friendly websites. 
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MODULE 1 

WORD PROCESSING 

 

LEARNING OUTCOMES 

By the end of this Module, students will be able to: 

• Learn how to open, save, and edit documents. 

• Understand how to insert and delete files. 

• Learn to format margins and convert files to different formats. 

• Understand page styles, alignment, indents, and line spacing. 

• Learn about headers, footers, inserting images, and spell-check 

features. 

• Understand the process of mail merging. 
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Notes Unit 1.1 Working with Documents 

 

1.1.1 Working with Documents: Opening, Saving, Editing Files, 

Inserting, Deleting Files 

With the new era of digital documentation, managing documents is 

no longer a luxury but a necessity! Regardless of whether you are a 

student, a working professional, or just some individual bravely going 

into the public spider web of life the management of digital 

information is critical. At its most fundamental level, document 

management includes a variety of practices and techniques suitable 

for orderly, easy and specific storage, preservation, retrieval, and 

renew of the digital files. In this Module, we will focus on the basic 

features of a very popular word processor (Microsoft Word) used to 

create word documents and edit documents. From opening and 

creating files to formatting and editing them we will look at the basic 

processes that underlie most of the normal tasks that you Explore – 

whether you are going to write an app, process those files or do it all 

at once with our method. So you to step ground into the digital 

frontier without getting lost. As a result, smart document management 

leads to higher productivity, less stress, and more control over your 

digital pipeline. By following the skills mentioned in this guide, you'll 

know how to walk through your documents like a pro, so that your 

important data is always at hand, whatever, wherever, and whenever 

you are. 

Opening a Document in MS Word 

When working with any existing document, the first thing you will do 

is, of course, open it. Microsoft Word creates an easy way for you to 

find your files, no matter where they are stored on your computer or 

cloud storage. First, you should open the Microsoft Word tool. After 

opening the program, you may see a start screen or a blank document. 

To open your existing documents, click the "File" tab in the top left 

corner of the Word screen. So clicking on File will bring up the 

backstage view to file management options. Choose “Open” from 

this view. A box will open, letting you navigate through your 

computer’s file system (or you’re One Drive or any linked cloud-

storage accounts). Your left-hand pane can let you move through your 

folders, and the right-hand pane allows you to pick the proper place 

where your document is located. When you find the file you want, 
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Notes click on it to select it. You can subsequently select the "Open" button 

in lower right of the dialog box. By doing this, the document chosen 

will be opened on the Word interface and editing or viewing it will be 

possible. In some versions of Word, the start screen or the "Open" 

view may also show a list of recent documents, which can assist you 

with quick access to files you have recently worked on. If your 

document is saved to a cloud service (such as One Drive) you might 

need to sign in to your Microsoft account to get the document. With 

the current cloud service integration, access to your documents from 

any device makes your work even more accessible. 

1.1.2. Creating a New Document 

When you start a new document that is where it all begins. You can 

start with a blank page or a template in Microsoft Word, but the 

application is an easy to work with. First, open the Microsoft Word 

application. When the program is started, you will see a start screen. 

Over here, you have a few options to one create new document. Click 

on the "Blank document" option to create a blank document. It will 

open a new blank document waiting for you to type. If you would 

rather use a pre-designed template, check out the different options in 

the template gallery. There are a variety of different templates readily 

available on Microsoft Word from documents to resumes to letters and 

even brochures. You can then explore categories of templates or 

search using the search bar to find everything you need. After you 

find a template that you like, click on it to see a preview. If you like 

the template, hit the Create button. This will create a new document 

with pre-loaded field elements for the selected template that you can 

customize. Your new document will now be ready, and you can either 

start typing the content if you have a blank document, or if you have 

used the template, your document will be loaded with some prefilled 

content. Now the cursor will be in the top left of the document, a 

perfect place for you to begin typing. Enter some text using the 

keyboard, and then one of the formatting buttons found in the Word 

ribbon above to do so. Opening a Document in Word is a Simple 

Process You can easily open a new document in Word and start 

working on your writing right away. 

1.1.3 Saving a Document 

A thing that would let your work persist after you left that site. And 

then there are many options available on Microsoft Word for saving 
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Notes the document depending on where you wish to save the document to 

and in which format you wish to save the document. To save a 

document, click on the "File" tab in the upper-left corner of the Word 

window. This opens the backstage view. Choose “Save As” from this 

view. Your choice in this section lets you determine just where you 

wish to save your document and what type of file. Then, you see a 

dialog box asking you to select a location. You can choose a folder on 

your computer’s hard disk, an attached external drive or a cloud 

service such as One Drive. You may be prompted to sign in to your 

Microsoft account if you decide to save it to One Drive. After 

choosing the exact location you want, you need to give it a file name. 

File name: It should be descriptive enough and easy to remember. 

Added for the ease of finding the file later now, we have to choose 

the file format. Microsoft Word documents are saved in its. Doc or 

docks, which should work with most versions of Word from 2007 

onwards. But other formats such as. Pdf, rtf, or. txt, depending on 

your needs. For instance, if you do not need Word for your document 

to become opened and to be viewed, you can save your document as a 

PDF file. Now that you've chosen the location, file name, and format, 

hit the "Save" button. This will save your document in the location 

you specified and you can continue working on it.  

 

Figure 1.1: Word Documentation 

[Source: https://www.onlyoffice.com] 
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Notes Leading me to believe that saving your work is a good idea, especially 

when you're working on a long document (or one that you just 

happened to get a little overzealous with). You can save your changes 

quickly (Ctrl + S) or (by clicking the save icon in the Quick Access 

Toolbar. 

1.1.4 Editing an Existing Document 

Editing an Existing Document Edit + 4 more rows. First, open the 

document you want to apply changes to, as discussed in the 

previously in the "Opening a Document in MS Word" section. Then, 

you open the document and begin editing it. To change the text, click 

on any part of the document to place the cursor. Then it is possible to 

type to insert, remove or change some words. Microsoft Word offers 

various formatting options to change the aesthetic of your text. 

(These options are found in the "Home" tab of the Word ribbon.) Use 

the font controls to set a different font, increase or decrease font size 

and even change the color. You can even use bold, italics or underline 

formatting to emphasize particular text. We use the paragraph 

controls to set the alignment, spacing, and indentation of paragraphs. 

You would even be able to put down bulleted lists or numbered lists. 

Apart from editing text freely, you can actually edit images, tables, 

and many other objects in your document. To modify an image, click 

on it to select it. You can then use the picture tools to resize, crop or 

change the different picture effects on that image. Click on a table to 

select, to edit it. After that, you can use the table tools to add and 

delete rows and columns, resize cells, and apply formatting. You 

should save your work constantly while modifying your document. 

Basic data exportpopularscience.com. Ctrl + S is a keyboard shortcut 

to quickly save your changes, or you can click the save icon in the 

Quick Access Toolbar. To save your progress and most importantly 

avoid losing any work due to unexpected interruptions. Editing an 

existing document in Word is a straightforward process, allowing you 

to easily update and refine your work. 

1.1.5 File Object Embedded into a Document 

Inserting a file into an existing document lets you combine content 

from another source into your document making it more efficient and 

adding thoroughness to the document. Using Microsoft Word is the 

easiest way to insert text from another file. First, navigate to the 

document in which you want to paste the content. Place your cursor 
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Notes to where you want to insert the text. Afterwards, on the Word ribbon, 

go to the Insert tab. In the "Text" group, select the Object dropdown 

menu. Choose “Text from File” from the dropdown menu. It will 

bring up a dialog box which will let you navigate your computer's file 

system to find the file you want to include. Find the folder with your 

file and select it. If you notice that the button on the file label reads “” 

on your right-hand side, once you’ve selected the file click “Insert” 

The chosen file’s content will appear inserted into your document at 

the location of your cursor. When inserted, the text will often keep its 

original formatting, but you can then use the different formatting 

options within the Word ribbon to modify it as you wish. Inserting a 

file into your document is useful, when you want to bring content of 

different sources together or include a pre-written section of another 

document. It can be time-consuming and requires you to copy or 

paste the app content to use it manually. The inserted file should be a 

type supported by Microsoft Word like. Docx. Rtf, or. Txt. You can 

use this page to get help inserting a document file in an unsupported 

format, potentially by converting it to a supported format first. 

 

1.1.6 Deletion of a File or Contents (Continue from above) 

Deleting content and files in Microsoft Word is as simple as the 

mechanisms available. To remove text or other content from within a 

document, first select the content that you want to delete. When you 

select the text by clicking and dragging your mouse. Click on an 

image or other object to select it. After you've selected the content, 

Fig 1.2: Word Document  

[Source: http:/www.onlyoffice.com] 
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Notes you can delete it in a few different ways. The most common method 

pressing down on your keyboard "Delete" or "Backspace" key. It’s 

important to know that the “Delete” key will delete whatever is 

selected, and the “Backspace” key will delete and shift everything 

after it to the left. Another way you can remove highlighted content is 

to right-click on it and chooses the "Cut" option from the context 

menu. It will delete the actual content (which will be stored in the 

clipboard if you need to access it elsewhere). To delete an entire 

paragraph, you can also triple-click anywhere inside that third 

paragraph to highlight it (or triple-tap in the case of a mobile device) 

and then press “Delete” or “Backspace.” To delete an entire file, you 

will have to use your computer's file explorer. Open up the folder 

where the file you want to delete is located. On the file, click with the 

right mouse button and from the context menu select "Delete". Your 

screen should pop up a confirmation dialog box that may ask you to 

verify deletion. Click "Yes" to proceed. When a file is deleted, it 

usually goes into the Recycle Bin or Trash, from which you can 

restore it if necessary. To permanently remove the file, you must 

empty the Recycle Bin or Trash. Deleting files is usually a rather 

irreversible process so be careful when doing this. There is no specific 

guidance or information on that, so be sure you have a backup copy 

of the file or make sure you don't need the file before deleting it. 

Deleting Content in a Specific Document You can delete content 

within a document similar to a way you would delete any generic 

objects in Word, such as text, images, or any type of objects. This 

prerequisite is important in destroying entire files, as the only way 

around this would be to perform a bit more care, but to also ensure 

correct functioning of the system. 

1.1.7 Formatting a Document 

Formatting Document Editing, which Blog will be Very Attractive 

and Ready-Made There is various formatting options available in 

Microsoft Word, which helps you format your document according to 

your requirements. Most of the commonly used formatting tools are 

found in the Home tab of Word ribbon. In the group called Font, you 

can modify font type, size, colour and style. You can also exert bold, 

italics, underline, etc., within your text. Under the "Paragraph" group 

you can set how your paragraphs are aligned, spaced and indented. 

And the “Styles” group gives you tons of formatting styles you can 
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Notes apply to your text. Working with styles makes your document looks 

consistent and saves you time and efforts. You click the style you 

want in the Styles gallery. The “Layout” tab contains options for 

changing the margins of, orientation and size for your document. You 

can even insert breaks page breaks, section breaks, columns. To 

specify the margins, select the “Margins” dropdown menu, then 

choose a pre-defined margin setting, or create custom margins. Under 

the Layout tab, click the Orientation drop-down and choose the 

Portrait or Landscape. The "Design" tab provides options for applying 

document themes and color schemes to ensure your document has a 

consistent and professional appearance. Themes change the overall 

layout of your document, like fonts, colors, effects, etc. From the 

"Insert" tab you can insert an object in your document, image, table, 

shape, chart and many more. You can also add headers, footers, and 

page numbers. The “Review” tab contains features for proofreading 

and editing your document, including spelling and grammar checks, 

thesaurus, etc. This is also a useful way to use the Track Changes 

and Comments features while collaborating with others on your 

document. For your document needs, even a simple formatting tool 

can go a long way in enhancing the look and feel of the text, bringing 

out focus and relevance in the content. Overall, Microsoft Word by 

following some formatting tools to convert your documents in a way 

so that they look professional and polished in communicating your 

documents. 

1.1.8 Track Changes and Comments 

Document creation is often collaborative, and Microsoft Word has the 

tools to help with that process. Let users comment and edit and track 

changes: The “Track changes” and “comments” features let you track 

your edits to ensure everyone is on the same page, including feedback. 

This is easily done by clicking on the "Review" tab and then clicking 

on the "Track Changes" button. The Track Changes mode highlights 

any changes you make in the document such as editing, deletion and 

formatting when it is active. It allows other contributors to review the 

fact you have made changes, and to accept or reject them. You can 

highlight the text by placing the mouse cursor over it, then clicking 

the New Comment button in the Comment group. A comment bubble 

will pop up in the margin, where you can type your response. The 

comments area is useful to provide context or to propose changes or 
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Notes ask questions. Then in Review tab, go to Changes group to accept or 

Reject changes. Instead, you can skim through the changes by hitting 

the “Previous” and “Next” buttons. Click the "Accept" button to 

accept a change. To accept a change, click the button to accept it. 

Note: You may also approve or deny every change at once by clicking 

on the dropdown arrow next to the "Accept" or "Reject" button, then 

selecting the option. Comments can be resolved or deleted as well. To 

resolve a comment, right-click it and choose “Resolve Comment.” It 

will serve as a signal that the comment has been addressed. To do 

this, right-click on the comment and select “Delete Comment.” The 

Track Changes and Comments features are great for creating 

documents collaboratively. They enable you to track changes, give 

feedback and make sure everyone who is contributing is on the same 

page. These capabilities allow you to make the most out of 

collaborative writing and produce quality documents. 

 

1.1.9 How to Save and Export Documents in Various Formats 

Microsoft word offers the option to save documents in different 

formats according to the needs. When saving a document as a 

different format, first click on the “File” tab and then “Save As.” 

Close the “Save As” dialog opens a dropdown “Save as type. 

Followed by this menu to choose the required file format. The default 

format is. Docx, but you can select from a large variety of different 

formats, analogous to. Pdf, Rtf, Txt, and. html. Saving a document as 

a PDF is especially handy when you want to make sure that the 

document can be seen on any device without Microsoft Word. When 

Fig 1.3: Track Changes and comments 

[Source: https:/www.onlyoffice.com] 
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Notes you save to PDF format, the files maintain the formatting and layout 

of your document, making them perfect for sharing and printing. 

Choosing to save a document as an RTF (Rich Text Format) can be 

useful when you want to maintain the document's formatting but you 

need to be able to open the document in a different word processing 

program. RTF File Rich text format opening most word processors. 

Saving a Document as Plain Text (Splitting the file as txt file 

removes any styles, leaving only the text. Use this format when you 

need to strip out all the formatting and get just the text from the 

document. How to Save Document as HTML (It saves the document 

as a web page (html) file that is useful if you intend to publish the 

document on the web. HTML document are pages that run on the web 

and will open on any web browser. Not only can you save the 

document into various formats, but you can also export them. The 

option is activated by clicking "File" and selecting "Export" and 

allows you to find additional options whenever making your 

document. For instance, you might export your document as a PDF 

file or a file in the XPS (XML Paper Specification) format. You can 

also turn your document into a video or animation. Saving and 

exporting documents in various formats will let you share your work 

with other people, have it published on the web, or utilize it in other 

applications. So by working through the various formats and options, 

you can no longer say I cannot open this or that document. 

1.1.10 Margins: Converting Files to Different Formats Using 

Toolbars 

Word and other document processing software give users many 

options for formatting and file conversion. For instance, fine-tuning 

your margins and saving your files into other formats are necessary 

for format compatibility and document “cleanliness.” Table of 

Contents Topics Introduction the Function of Margins in Word 

Processing Converting Files with Bars Final Note I Introduction This 

guide teaches you about margins and the fact that a document can be 

converted into another by using the toolbars provided in this 

program.  

Understanding Margins in Document Formatting 

Margins are the blank spaces surrounding the content of a document. 

They play a crucial role in defining the overall layout and readability 



 

13 
 

Notes of a document. Proper margin settings enhance document aesthetics 

and ensure that text is not cut off during printing. 

Importance of Margins 

• Ensures text alignment and spacing. 

• Provides room for binding or printing. 

• Enhances readability by preventing overcrowding of text. 

• Gives a professional look to official documents. 

Setting Margins in MS Word 

To set margins in MS Word: 

• Open the document in MS Word. 

• Click on Layout in the toolbar. 

• Select Margins from the dropdown menu. 

• Choose predefined margin settings such as Normal, Narrow, 

Moderate, Wide, or set custom margins. 

• Click OK to apply changes. 

Customizing Margins 

For customized margins: 

• Click Margins > Custom Margins. 

• Enter the desired values for Top, Bottom, Left, and Right. 

• Click OK to confirm changes. 

Page Orientation and Margins 

The margin setup may vary depending on the page orientation: 

• Portrait Orientation: Used for standard documents. 

• Landscape Orientation: Suitable for tables and wide content. 

Converting Files to Different Formats Using Toolbars 

Document conversion is necessary for ensuring compatibility across 

different devices and software. Microsoft Word and other tools 

provide built-in features to convert files into formats like PDF, 

HTML, TXT, RTF, and more. 

Common File Formats for Conversion 

• DOCX: Default MS Word format. 

• PDF: Used for secure and universally readable documents. 

• TXT: Plain text format without formatting. 

• RTF: Rich Text Format, compatible with multiple word 

processors. 

• HTML: Used for web publishing. 

Converting to PDF Using the Toolbar 
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Notes PDF is one of the most commonly used formats for document sharing. 

To convert a Word document to PDF: 

• Open the document. 

• Click File > Save As. 

• Select PDF from the format dropdown. 

• Click Save. 

Alternatively, use the Export option: 

• Click File > Export. 

• Select Create PDF/XPS Document. 

• Click Publish. 

Converting to Plain Text (TXT) Using the Toolbar 

• Click File > Save As. 

• Choose Plain Text (.txt) as the file format. 

• Click Save. 

• A dialog box may appear prompting for encoding settings—

choose UTF-8 for compatibility. 

Converting to Rich Text Format (RTF) 

• Click File > Save As. 

• Select Rich Text Format (.rtf). 

• Click Save to store the file with formatting compatibility 

across different text editors. 

Converting to HTML for Web Publishing 

To convert a document for web publishing: 

• Click File > Save As. 

• Choose Web Page (.html, .htm). 

• Click Save to generate an HTML version. 

Batch Conversion of Multiple Files 

For multiple file conversions: 

• Use MS Word Macros. 

• Utilize third-party tools like Adobe Acrobat, Zamzar, or online 

converters. 

Using the Print to PDF Option 

Another method to convert files into PDF is using the Print function: 

• Click File > Print. 

• Select Microsoft Print to PDF as the printer. 

• Click Print and save the output as a PDF file. 
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Notes Unit 1.2: Page Styling and Formatting 

 

1.2.1 Page Style, Alignment – Indents, Line Spacing, Borders, and 

Shading 

Page Styling and Formatting 

So not for date formatting or page styling. Word and other word 

processors have various tools to provide styling on pages, alignment, 

indents, line spacing and borders and shading to pages and content. 

This guide details these topics and more. 

Page Style 

Page style refers to the overall look of the document (including 

margins, page orientation, headers, footers, and background settings). 

Margins 

• Margins specify how far from the edge of a document and 

the text. 

• Set margins in MS Word: 

▪ Click Layout > Margins. 

▪ Use the preset margin options, or select Custom 

Margins to enter specific numbers. 

Page Orientation 

• Specifies whether a document is in Portrait (vertical), or 

Landscape (horizontal) mode. 

(To change, go to Layout > Orientation.) 

Headers and Footers 

• Headers: text appearing at the top of every page and footers: 

text appearing at the bottom of every page 

• To add: Insert > Header/Footer and choose a style. 

Good for page numbers, document titles, and company logos. 

Page Background 

• Could be colors, images, watermarks. 

• Format using Design > Page Color or Watermark 

Alignment in Documents 

Alignment explains the position of text and objects in a document. 

Types of Text Alignment 

• Left alignment: The default, where the text begins at the left 

margin. 

• Right Alignment: Makes text block flush right. 

• Centre Alignment: Centres the text on a page. 



  

16 
MATS Centre for Distance and Online Education, MATS University 

 

Notes • Justified Alignment: spaces out the text so it justifies on both 

the left and right margins. 

Image-Object Association 

• Layout Options are used to align images, tables, and charts. 

• Either Text Wrapping options (eg Tight, Square, and Behind 

Text) allow for images to flow with text. 

Indents in Documents 

Indents help to tighten the space between the text and margins, which 

makes the text easy to read. 

Types of Indents 

• First Line Indent: Indents the first line of a paragraph. 

• Hanging Indent: Indents the second and subsequent lines. 

• Left Indent: Indents text from the left margin. 

• Right Indent: Indents text from the right margin. 

Setting Indents 

• Quickly: Use the Ruler to make adjustments 

Indent more precisely using the Paragraph Settings via Home > 

Paragraph > Indentation. 

Line Spacing 

The space between the lines of a paragraph is called line spacing 

which increases readability. 

Common Line Spacing Options 

• Single (1.0): The default amount of space between the 

paragraphs with few spaces. 

• 1.5 Lines: Provides added space for a clearer reading 

experience. 

• Double (2.0): Used frequently in academic and formal writing. 

• Space adjustment: Hand-adjusted. 

Adjusting Line Spacing 

• Home > Paragraph > Line Spacing. 

• Choose Default or Enter Custom Spacing Values. 

Borders and Shading 

Inserting borders and shading adds dimension and visual depth to a 

document, drawing attention to key elements. 

Adding Borders 

• Borders can be used for the text, paragraphs, and within the 

tables. 

• Go to Design> Page Borders. 
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Notes • Box, Shadow, 3D, Custom Borders. 

Applying Shading 

• Shading applies background color in the text or paragraphs. 

• Home > Shading (paint bucket icon) 

• Great for drawing attention to important parts. 

1.2.2 Header and Footer Setting 

MS Word file presents itself well with meaningful headers and 

footers. They include the same information like page numbers, 

document titles or author names on every page. 

Header and Footer Access 

Here's how to open the header and footer in MS Word: 

• Click on the Insert tab. 

• Choose Header or Footer on the ribbon. 

• Select a predefined style or define your own header/footer. 

• To exit, click anywhere outside the header/footer area 

Insert Text in the Header and Footer 

After entering the header or footer section: 

• Enter text like document title/date. 

• Format the text using bold, italic and font size. 

• Align text with the buttons for left, centre or right alignment. 

Inserting Page Numbers 

• Go to the Insert tab. 

• Select Page Number in the Header & Footer group. 

• Select a placement (Top, Bottom, or Page Margin). 

• Choose a style of numbering. 

How to customize this page number format 

• Click Page Number > Format Page Numbers. 

• Select Number format (1, 2, 3 or I, II, III). 

• Choose whether to continue numbering from the last section, or 

start at what number. 

Odd-Even Header and Footer Issue 

• Double-click in the header or footer area. 

• Select Different Odd & Even Pages under the Design tab. 

• Use different text or elements on odd and even pages 

Add Different Headers and Footers to Each Section 

• Move the cursor to the start of the section where you want 

another header/footer. 

• Click Layout > Breaks > Section Break (Next Page). 
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Notes • Double-click the header/footer, unlink it from previous. 

• Per section edit header/footer 

Insert Header/Footer Date and Time 

• Double-click inside the header or footer. 

• Go to Insert > Date & Time. 

• Select a date format and click the Update Automatically 

checkbox if desired. 

Insert Photos, Logos, and Watermarks 

• For image/logo insert as header/footer, click inside the 

header/footer and select Insert > Pictures. 

• Resize the image and align it accordingly. 

• Design > Watermark, and choose a predefined or custom 

watermark 

Removing Headers and Footers 

• Insert > Header/Footer 

• Select Remove Header or Remove Footer. 

• The header and the footer will be removed from the 

document. 
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Notes Unit 1.3: Inserting Illustrations 

 

1.3.1  Drawing: Inserting Clip Arts, Pictures, and Files 

Introduction to MS Word Document Editing 

Microsoft Word is popular word processing software that enables 

users to efficiently create, modify, format, and customize documents. 

[MS Word Drawing Tools – Feature] 

Microsoft Word has some native drawing tools that assist the users in 

inserting shapes, lines and other design objects into the documents. 

Accessing the Drawing Toolbar 

Click ‘Insert’ then ‘Shapes’ to get drawing tools, or you can use the 

‘Draw’ option to draw freehand. 

Inserting Clip Art in MS Word 

• Click on the ‘Insert’ tab. 

• Choose ‘Online Pictures’ (or ‘Clip Art’ in older versions) 

• Find the clip art you want and add it to the document. 

Copy Paste Pictures from Computer 

• Click on the ‘Insert’ tab. 

• Under ‘Pictures’, choose ‘This Device’. 

• Find the image file and add it to the document. 

Formatting Inserted Images 

• Select the inserted image; go to ‘Picture Format’. 

• Make adjustments using tools such as crop, resize, and effects. 

Inserting Files into MS Word 

• Go to ‘Insert’ > ‘Object’ > ‘Text from File’ 

• Choose the list, (word, pdf or option of supported formats) and 

add it to document. 

Using Smart Art for Visual Representation 

• Navigate to ‘Insert’ > ‘Smart Art’. 

• Choose a diagram style to visually represent data or concepts. 

Custom Drawings in MS Word and You 

• Use the ‘Draw’ tab (found in recent versions of Word). 

• Tap pen, pencil or highlighter to make freehand drawings. 

How to Saving and Exporting Word Documents 

• Click ‘File’ > ‘Save As’. 

• Select the appropriate format (e.g., DOCX, PDF, etc) and save 

your document. 
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Notes For inserting images of each step, screenshots can be taken with the 

help of Snipping Tool or Print Screen function. 

Insert Clip Arts, Pictures, and Files in MS Word 

How to Draw in MS Word? 

 

Microsoft Word is more than just a word processor; it offers great 

functions for inserting and manipulating visual elements (clip arts, 

pictures, files) in documents. This guide explains how to use these 

features effectively with a step-by-step guide. 

The Pen and Brush Drawing Tools 

MS Word has different drawing tools such as shapes, Smart Art, 

charts, and text boxes. These tools can be used to create visually 

stunning documents. 

Adding Clip Arts to MS Word 

• So first open MS word and click on a location where you 

want to put the clip art. 

• Click on the Insert tab. 

• Select Online Pictures (particularly since newer versions of 

Word do not include Clip Art)." 

• Types in the keyword of the image you want to search for and 

hit enter. 

• Select the image and then click Insert to insert it in the 

document. 

Inserting Pictures from a File 

Fig 1.4: Insert Clip Arts 

[Source: https:/PCbooks.in] 
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Notes • Navigate to the Insert tab of the ribbon. 

• Choose Pictures > This Device. 

• Navigate through to find the image you want to add. 

• Then click Insert to add it to your document. 

Inserting Online Pictures 

• Navigate to the Insert tab. 

• Click Online Pictures. 

• Google an image by typing in keywords. 

• Select an image, and then click Insert. 

• Resize and reposition accordingly. 

Cropping and Placing Images 

• Click on the inserted image. 

• Hold down the corner handles to resize while keeping the 

aspect ratio. 

• Use the Layout Options for things like Square, Tight, or 

Behind Text wrapping styles. 

Applying Effects and Styles to an Image 

• Select the image. 

• Click on Picture Format. 

• Use Picture Styles to apply predefined styles. 

• The Final cropping, Colouring and Artistic effects will further 

be applied. 

Grouping and Layering Objects 

• Hold Ctrl and click to select multiple images or shapes. 

• Right-click and choose Group. 

• To layer, right-click on an object and then select Bring 

Forward or Send Backward. 

Adding Shapes and Smart Art for Visual Appeal 

• Click on Insert > Shapes. 

• Select the shape you want and draw it on document. 

• To create structured graphics, click Insert > Smart Art. 

• Change Smart Art elements' colors, styles, and text. 

Saving and Exporting Documents with Drawings 

• Save your document normally as you would using File > Save 

As. 

• To save as a PDF go to File > Export > Create PDF/XPS. 

• This guide is applied to Microsoft Word and I'm sure it is the 

best choice for you. 
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Notes • Through this guide, you will learn an effective way to insert 

and manage drawings in MS Word. Allied with this should be 

screenshots of each other step. 
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Notes Unit 1.4: Word Document Review 

 

1.4.1  Word Completion: Spell Check 

Discuss the significance of tools like word completion and spell 

check in word processing software, and how they enhance writing 

speed and accuracy. 

Understanding Word Completion 

Word completion is a language processing technique that enables 

users to input text more quickly by predicting the word they are 

typing and suggesting options based on the entered characters. It helps 

identify misspelled words in the text. Explain how spell check 

works, from dictionaries and algorithms that detect misspelled words 

to your computer making suggestions. 

Enable Word Completion in MS Word 

• How to Activate and Configure Auto-Completion in 

Microsoft Word 

• Using Spell Check in MS Word 

• Helpful hints on how to run a spell check in MS Word 

automatically and manually, with step-by-step instructions 

Customizing the Spell Check Feature 

How to change the spell check settings, including how to add words 

to the dictionary, ignoring specific words or terms, and changing the 

language. 

Spell Check Misses Plenty of Common Errors 

Error types (typos, grammatical mistakes, contextual errors) and how 

spell check recognizes them. 

Spell Check and Word Completion Limitations 

Acknowledge scenarios in which spell check and word completion 

would not work, including homophones, proper nouns, and technical 

vocabulary. 
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Notes Unit 1.5: Mail Merge 

 

1.5.1 Mail Merging 

Mail Merge is a very convenient function of any word processing or 

spreadsheet software that allows you to create; Personalized letters / 

labels / emails that combine a main document with the available data 

sources. E.g. well known mail merge with office word to send bulk 

communication with different details to different people. 

How Mail Merging Works 

There are three major components of mail merging: 

• Template Document: The main document with standard text 

and merge fields for customized information. These can be 

letters, invoices, or certificates. 

• Data: A list of the personal information like name, address 

and phone numbers. It is typically stored in an Excel 

spreadsheet, CSV file, or database. 

• Merge Fields: Also known as merge fields, these are the 

command types placed in the main document that will be 

replaced with actual data populated during the merging 

process. 

 

Fig 1.5: Mail Merge 

[Source: https://www.onlyoffice.com] 
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Notes Steps to Mail Merge in Microsoft Word 

Prepare the Data Source: 

• Build an Excel sheet with clearly labeled columns (e.g., First 

Name, Last Name, Address, etc.). 

• Make sure the data does not have any blank rows/intermittent 

formatting issues. 

 

Step 1: Open Microsoft Word and Choose Main Document Type: 

• Under Mailings > Start Mail Merge select document type as 

Letters or Labels / Emails / Envelopes. 

Connect the Data Source: 

• In the dropdown menu select Recipients > Use an Existing 

List and browse to the Excel file. 

Insert Merge Fields: 

• Enter cursor position for personalized data to appear. 

• Selecting Insert Merge Field gets you to choose a specific 

column from the data source. 

Preview the Merged Document: 

• Click on Preview Results to see what the merged data looks 

like in your document. 

Complete the Merge: 

• Click Finish & Merge to create the final documents, as 

separate files or for printing. 

Benefits of Mail Merge 

• Time and labour saving in generating bulk personalized 

documents 

• Lowers the chances of mistakes that come with manual data 

entry. 

• Improves the efficiency of corporate communications, 

marketing, and invitations 

Summary : 

This module introduces learners to the fundamental tools and features 

of word processing applications. It covers document creation and 

editing, helping users develop efficiency in managing digital text. 

Learners explore page styling and formatting, including margins, 

alignment, headers, footers, and design elements that enhance 

readability and presentation. The module also includes methods for 

inserting illustrations like images, shapes, and charts, making 

documents visually engaging. Additionally, review tools such as track 

changes, comments, and spelling/grammar check are studied for 
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Notes collaborative editing. Finally, the concept of mail merge is 

introduced, allowing personalized mass communication through 

automated integration of a document with data sources. By the end, 

learners gain proficiency in creating professional, structured, and 

collaborative documents. 

 

MCQs: 

1. Which shortcut key is used to save a document in most 

word processors? 

a) Ctrl + S 

b) Ctrl + P 

c) Ctrl + X 

d) Ctrl + V 

Ans a) 

2. What is the default file extension for a Microsoft Word 

document? 

a) .txt 

b) .pdf 

c) .docx 

d) .xlsx 

Ans  c) 

3. How do you insert a header in a Word document? 

a) Insert → Footer 

b) Layout → Header 

c) Insert → Header 

d) View → Header 

Ans c) 

4. Which tool is used to check spelling errors in Word? 

a) Format Painter 

b) Grammar Check 

c) Spelling and Grammar Check 

d) AutoCorrect 

Ans c) 

5. What is mail merge used for? 

a) Sending bulk emails 

b) Merging two documents 

c) Creating personalized documents 

d) Formatting text 

Ans a) 
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Notes 6. Which feature helps in setting document margins? 

a) Home 

b) Page Layout 

c) Insert 

d) Review 

Ans b) 

7. What does a footer contain? 

a) Page Number 

b) Title of the Document 

c) Author Name 

d) All of the above 

Ans a) 

8. What happens when you press Ctrl + Z in Word? 

a) Redo 

b) Undo 

c) Copy 

d) Delete 

Ans   b) 

9. The Alignment option is found under which tab in Word? 

a) Home 

b) Insert 

c) Layout 

d) Review 

Ans a) 

10. How do you insert an image in Word? 

a) File → Insert Image 

b) Insert → Picture 

c) View → Image 

d) Format → Picture 

Ans  b) 

 

Short Questions: 

1. How do you open and save a document in Word? 

2. What is the purpose of the Page Layout tab? 

3. Explain the steps to convert a document into a different 

format. 

4. What is the use of headers and footers? 

5. How can you check the spelling of words in Word? 
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Notes 6. What is the use of mail merging? 

7. Explain different types of alignments in Word. 

8. What are margins, and how can you set them? 

9. How do you insert a table in Word? 

10. How do you apply shading and borders to a document? 

Long Questions: 

1. Explain the process of creating and saving a document in 

Word. 

2. How can you format a document using styles, line spacing, 

and indents? 

3. Explain how to use headers and footers in a document. 

4. What is the importance of spell check and word completion in 

Word processing? 

5. How do you insert images and clip arts in a Word document? 

6. Explain the mail merge feature with steps. 

7. What are different page styles and alignments available in 

Word? 

8. Write the steps to convert a Word document into a PDF file. 

9. Discuss the process of inserting and deleting files within a 

document. 

10. Explain how Word processing has improved document 

management. 
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MODULE 2 

SPREADSHEET 

 

LEARNING OUTCOMES 

By the end of this Module, students will be able to: 

• Understand the concept and applications of spreadsheets. 

• Learn how to open, save, and set up spreadsheet files. 

• Understand spreadsheet addressing: rows, columns, and cells. 

• Learn how to insert data, cells, columns, rows, and sheets. 

• Explore the use of external files like images and clipart in 

spreadsheets. 

• Understand the use of the formula tab in spreadsheets. 
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Notes Unit 2.1: Introduction to Spreadsheet 

 

2.1.1 Spreadsheet and Its Applications 

A cell is a merger between each row and each column, so any cell can 

contain text, numbers, formulas, or functions. Spreadsheets are an 

incredibly useful tool to help you organize, track, and analyze data in 

virtually any field. The modern spreadsheet began with VisiCalc in 

1979, evolved into Lotus 1-2-3 in the 1980s and is now led by 

Microsoft Excel, Google Sheets, Apple Numbers and LibreOffice 

Calc, among others. These applications have changed the way we 

interact with numerical data, enabling complex operations to be 

performed without requiring any knowledge of coding. 

 

Spreadsheet Applications 

Financial Management 

These are for financial planning, budgeting, and analysis, which are 

all widespread uses of spreadsheets. They allow users to: Personal 

Budget Tracker: a personal budget tracker may have categories for 

income, expenses, savings, and investments. Users have the option to 

build formulas that measure monthly savings, track behaviour 

patterns, and view financial data via charts. 

• Column A: Category (Rent, Groceries, Utilities, etc). 

• Column B: Budgeted Amount 

• Column C: Actual Spending 

 

Figure 2.1:  Spread Sheet 

[Source: https://www.upgrad.com] 
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Notes • Column D: Difference (formula (in D2): =B2-C2) 

Example: Business Financial Statements Businesses use 

spreadsheets to prepare and update balance sheets, income statements 

and cash flow forecasts. These sheets can interconnect to create a 

holistic view of financial health. 

• Sheet 1: Income Statement 

• Sheet 2: Balance Sheet 

• Sheet 3: Cash Flow Statement 

• Sheet 4: Financial ratios (calculated from figures in other 

sheets) 

Data Analysis 

With spreadsheets, you have powerful tools which can be used to 

analyze large datasets and identify trends. 

For example: A sales dashboard can monitor performance by region, 

product, and period. Managers can easily at a glance discover top 

fertilizer products, or how little fertilizer sold in a region, using pivot 

tables and charts. 

Final Data: A sales transaction with Date, Product, Region, 

Salesperson, and Amount Data is modelled to summarize sales by 

product and region. 

Graphs: Visual display of trends over a period of time Research Data 

Analysis Example Researchers collect experimental or survey data 

and use spreadsheets to calculate statistics, spot correlations, and test 

hypotheses. 

• Column A-D: Raw data points 

• Column E-F: statistics (mean, median, standard deviation) 

• Column G: Statistical tests (t-tests & chi square tests) 

Inventory Management 

Fig 2.2: Inventory Management 

[Source: https://microsoftexcel.com] 
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Notes  

Businesses keep track of inventory levels; reorder points and product 

information using spreadsheets. 

For example, a simple inventory system may consist of: 

• Column A: Product ID 

 

• Column B: Product Name 

• Column C: Quantity on Hand 

• Column D: Reorder Point 

• Column E: Supplier Information 

• Column F :formula to highlight when stock is below reorder 

point 

Example: Automated Reorder List a more sophisticated approach 

could auto-generate purchasing orders: 

Sheet 1: Inventory 

Sheet 2: Purchase Orders (filled with products under reorder point) 

Sheet 3: Contact List 

Project Management 

They enable you to keep tabs on project schedules, resource 

allocation, and expenses. For example, Gantt chart similar is prepared 

in an excel can effective visualize project phases and dependencies: 

• Column A: Task Description 

• Column B: Start Date 

• Column C: Duration 

• Column D: End Date 

• Columns E-Z: Timeline (cells filled to represent task 

duration) 

Example: Resource Allocation A resource allocation spreadsheet 

tracks who is doing what and when: 

• Rows: Team members 

• Columns: Weeks or days 

• Cells: Assigned projects (color-coded project-wise) 

Educational Applications 

Teachers and students work with sheets for grading, simulations and 

learning exercises. 

Example: Teachers monitor student performance over a series of 

assignments: Grade Book. 

• Column A: Student Names 
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Notes • Columns B through M: Assignment Scores 

• Column N: Final Grade (formula to calculate weighted 

average) 

Example: Science experiment data Students document and analyze 

the results of experiments: 

• Column A: Trial Number 

• Column B-D: Measured Values 

• Column E: Calculated Results 

• Column F: A Comparison with the Theoretical Values 

Statistical Analysis 

Spreadsheets provide numerous statistical functions for data analysis. 

Example: Descriptive Statistics A dataset with calculated statistical 

measures: 

Raw data in range A1:A100 

Cell B1: =AVERAGE (A1:A100) 

Cell B2: =MEDIAN (A1:A100) 

Cell B3: =STDEV (A1:A100) 

Cell B4: =MIN (A1:A100) 

Cell B5: =MAX (A1:A100) 

Example: Correlation Analysis analyzing relationships between 

variables: 

• Column A: Variable 1 values 

• Column B: Variable 2 values 

Cell C1: =CORREL (A:A,B:B) (calculates correlation coefficient) 

Database Management 

Spreadsheets can function as simple databases for storing and 

retrieving information. 

Example: Customer Database A customer information database: 

• Column A: Customer ID 

• Column B: Name 

• Column C: Contact Information 

• Column D: Purchase History 

• Column E: Loyalty Points 

Example: Product Catalog a product inventory database with filtering 

capabilities: 

• Column A: Product ID 

• Column B: Category 

• Column C: Price 
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Notes • Column D: Quantity 

• Column E: Description 

Form Creation and Data Collection 

Spreadsheets can be used to create forms for data collection, 

especially in web-based applications like Google Sheets. 

Example: Event Registration Form A form collecting participant 

information: 

Form Fields: Name, Email, Phone, Dietary Restrictions  

Responses Sheet: Automatic collection of submitted data 

Example: Survey Analysis Responses collected through forms can be 

automatically analyzed: 

• Sheet 1: Raw response data 

• Sheet 2: Summary statistics and charts 

2.1.2 Working with Spreadsheet: Opening, Saving, File Setting 

Opening a Spreadsheet 

Microsoft Excel 

Example: Opening from File Explorer 

1. Navigate to the file in Windows Explorer 

2. Double-click the file to open it in Excel 

Example: Opening from Excel 

1. Launch Excel 

2. Click "File" > "Open" 

3. Navigate to the file location 

4. Select the file and click "Open" 

Example: Opening Recent Files 

1. Launch Excel 

2. Click "File" > "Recent" 

3. Select from the list of recently opened files 

Google Sheets 

Example: Opening from Google Drive 

1. Go to drive.google.com 

2. Navigate to the file 

3. Double-click to open 

Example: Opening from Sheets Homepage 

1. Go to sheets.google.com 

2. Click on a recent file or "Open file picker" 

3. Select the file to open 

Libre Office Calc 
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Notes Example: Opening from Start Menu 

1. Launch LibreOffice Calc 

2. Click "File" > "Open" 

3. Navigate to the file location 

4. Select the file and click "Open" 

Saving a Spreadsheet 

Microsoft Excel 

Example: Saving a New File 

1. Click "File" > "Save As" 

2. Choose a location 

3. Enter a filename 

4. Select a file type (e.g., .xlsx, .xls, .csv) 

5. Click "Save" 

Example: Saving an Existing File 

1. Click "File" > "Save" or press Ctrl+S 

2. The file will be saved with its current name and location 

Example: AutoSave Feature 

1. For Microsoft 365 subscribers with files stored in OneDrive: 

2. AutoSave is enabled by default (toggle appears in top-left 

corner) 

3. Changes are saved automatically as you work 

Google Sheets 

Example: Automatic Saving 

1. Google Sheets saves automatically as you work 

2. No manual save required 

Example: Offline Access 

1. Click the three dots in the upper right 

2. Toggle "Available offline" to enable offline access 

Example: Downloading a Copy 

1. Click "File" > "Download" 

2. Select format (Excel, PDF, CSV, etc.) 

3. File will be downloaded to your computer 

LibreOffice Calc 

Example: Saving for the First Time 

1. Click "File" > "Save As" 

2. Choose location and filename 

3. Select file format 

4. Click "Save" 
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Notes Example: Using Save as for Different Formats 

1. Click "File" > "Save As" 

2. Change the "Save as type" dropdown 

3. Common formats include ODS (native), XLSX (Excel), CSV 

(plain text) 

File Settings 

Microsoft Excel 

Example: Changing Document Properties 

1. Click "File" > "Info" 

2. View or edit properties like title, author, and tags 

Example: Protecting a Workbook 

1. Click "File" > "Info" > "Protect Workbook" 

2. Choose options like "Encrypt with Password" or "Mark as 

Final" 

Example: Setting Compatibility Mode 

1. Click "File" > "Info" 

2. If "Compatibility Mode" appears, click "Convert" to update to 

latest format 

Google Sheets 

Example: Sharing Settings 

1. Click the "Share" button in the top-right corner 

2. Enter email addresses or generate a shareable link 

3. Set permissions (Viewer, Commenter, Editor) 

Example: Version History 

1. Click "File" > "Version history" > "See version history" 

2. View, name, or restore previous versions 

Example: Offline Access Settings 

1. Click the three dots menu > "Settings" 

2. Toggle "Offline" to enable working without internet 

LibreOffice Calc 

Example: Document Properties 

1. Click "File" > "Properties" 

2. Set description, custom properties, and security options 

Example: User Data Settings 

1. Click "Tools" > "Options" > "LibreOffice" > "User Data" 

2. Fill in personal information used in documents 

Example: AutoSave Configuration 

1. Click "Tools" > "Options" > "Load/Save" > "General" 
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Notes 2. Set AutoSave interval and location 

2.1.2  Spreadsheet Addressing: Rows, Columns, and Cells, 

Referring Cells 

Understanding Row and Column Notation 

Spreadsheets use a grid system where columns are labeled with letters 

(A, B, C, etc.) and rows are labeled with numbers (1, 2, 3, etc.). 

Example: Basic Notation 

• Column A, Row 1 = Cell A1 

• Column C, Row 5 = Cell C5 

• Column Z, Row 100 = Cell Z100 

Example: Extended Column Notation After column Z, notation 

continues with AA, AB, AC, etc. 

• Column AA, Row 1 = Cell AA1 

• Column AZ, Row 10 = Cell AZ10 

• Column BA, Row 15 = Cell BA15 

Example: Maximum Dimensions 

• Excel: 16,384 columns (XFD) and 1,048,576 rows 

• Google Sheets: 18,278 columns (ZZZ) and 40,000 rows 

• LibreOffice Calc: 1,024 columns (AMJ) and 1,048,576 rows 

Selecting Cells 

Example: Single Cell Selection 

1. Click on the cell to select it 

2. The cell reference appears in the Name Box (top-left corner) 

Example: Range Selection 

1. Click and drag from the first cell to the last cell in the range 

2. Selected range is highlighted 

3. Range notation appears as A1:B10 (from cell A1 to cell B10) 

Example: Multiple Non-Adjacent Selections 

1. Select the first cell or range 

2. Hold Ctrl (Windows) or Command (Mac) 

3. Select additional cells or ranges 

4. All selected cells are highlighted 

Row and Column Operations 

Example: Selecting an Entire Row 

1. Click on the row number (e.g., click on "3" to select row 3) 

2. The entire row is highlighted 

Example: Selecting an Entire Column 
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Notes 1. Click on the column letter (e.g., click on "B" to select column 

B) 

2. The entire column is highlighted 

Example: Selecting Multiple Rows or Columns 

1. Click and drag across row numbers or column letters 

2. Or click the first row/column, hold Shift, and click the last 

row/column 

Referring to Cells 

Relative References 

Relative references change when a formula is copied to another cell. 

Example: Basic Relative Reference 

1. Enter formula =A1+B1 in cell C1 

2. Copy to cell C2 

3. Formula automatically updates to =A2+B2 

Example: Relative Reference in Calculations 

1. In cell E1, enter =C1/D1 (division) 

2. Copy down to E2:E10 

3. Each cell will calculate using values from its own row 

Example: Sequential Numbering 

1. Enter 1 in cell A1 

2. Enter =A1+1 in cell A2 

3. Copy down to A3:A10 

4. Cells will contain sequential numbers 1, 2, 3, etc. 

Absolute References 

Absolute references remain fixed when a formula is copied. They are 

indicated by dollar signs ($). 

Fig 2.3: Absolute References 

[Source: https://microsoftexcel.com] 
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Notes  

Example: Fixed Column Reference 

1. Enter formula =$A1*B1 in cell C1 

2. Copy to cell D1 

3. Formula becomes =$A1*C1 (A remains fixed, B changes to C) 

Example: Fixed Row Reference 

1. Enter formula =A$1*A2 in cell B2 

2. Copy down to B3 

3. Formula becomes =A$1*A3 (1 remains fixed, 2 changes to 3) 

Example: Fully Absolute Reference 

1. Enter tax rate in cell $H$1 

2. Create formula =B2*$H$1 in cell C2 

3. Copy to any cell in the spreadsheet 

4. Formula always refers to the tax rate in H1 

Mixed References 

Mixed references fix either the row or column but not both. 

Example: Multiplication Table 

1. Enter numbers 1-10 in A1:A10 (rows) 

2. Enter numbers 1-10 in B1:K1 (columns) 

3. In cell B2, enter =$A2*B$1 

4. Copy formula to range B2:K11 

5. Creates a multiplication table where each cell is product of 

row and column headers 

Example: Percentage Calculation 

1. Enter values in B2:B10 

2. Enter total in B11 

3. In C2, enter =B2/$B$11 

4. Copy down to C3:C10 

5. Each cell shows its value as a percentage of the total 

Named Ranges 

Named ranges allow you to refer to cells by meaningful names instead 

of cell references. 

Example: Creating a Named Range 

1. Select range A1:A10 

2. Click in the Name Box (left of formula bar) 

3. Type "Sales_Data" and press Enter 

4. Now you can use Sales_Data in formulas instead of A1:A10 

Example: Using Named Ranges in Formulas 
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Notes 1. Create named range "Costs" for range B1:B10 

2. Create named range "Revenue" for range C1:C10 

3. In cell D1, enter formula =SUM(Revenue)-SUM(Costs) 

4. Formula is more readable than =SUM(C1:C10)-

SUM(B1:B10) 

Example: Dynamic Named Ranges 

1. Create named range "This Month" with formula 

=OFFSET(A1,MONTH(TODAY())-1,0) 

2. Formula automatically points to the cell representing the 

current month 

3D References 

3D references allow you to refer to cells across multiple worksheets. 

Example: Summing Across Sheets 

1. Create sheets for each month (Jan, Feb, Mar) 

2. Each sheet has sales data in cell B5 

3. On summary sheet, enter =SUM(Jan:Mar!B5) 

4. Formula sums B5 from all sheets between Jan and Mar 

Example: Averaging Across Sheets 

1. Create sheets for each quarter (Q1, Q2, Q3, Q4) 

2. Each sheet has expense data in range A1:A10 

3. On annual sheet, enter =AVERAGE(Q1:Q4!A1:A10) 

4. Formula averages values from the same range across all 

quarter sheets 

2.1.3 Inserting Data: Insert Cells, Columns, Rows, and Sheets 

Inserting Cells 

Example: Inserting a Single Cell 

1. Right-click on cell where you want to insert 

2. Select "Insert" 

3. Choose shift direction (right or down) 

4. Cell is inserted, and existing cells move accordingly 

Inserting Multiple Cells Select range of cells same size as what you 

want to insert I'll provide you with a comprehensive guide on working 

with external files in documents, focusing on frames, clipart, pictures, 

and the Formula tab. I'll structure this for clarity and include plenty of 

examples. 

  



 

41 
 

Notes Unit 2.2 : Insert Tab 

 

2.2.1 External Files: Frames, Clipart, Pictures, etc. 

In modern document processing applications, the ability to 

incorporate external elements like frames, clipart, and pictures 

enhances both visual appeal and content quality. Additionally, the 

Formula tab provides mathematical functionality crucial for technical 

documents. This guide explores these features in detail, providing 

practical examples for each. 

Working with Frames 

Frames are containers that hold text, images, or other content, 

allowing for flexible positioning within a document. 

Types of Frames 

Text Frames 

Text frames contain text that can flow independently of the main 

document text. 

Example 1: Creating a Pull Quote In a magazine article, you might 

want to emphasize an important quote: 

1. Insert a text frame 

2. Format with a light background color 

3. Add larger, italic text with the quote 

4. Position it alongside the main text 

5. Add a border to make it stand out 

Example 2: Sidebar Information When creating instructional 

materials, you can use text frames for supplementary information: 

1. Create a narrow text frame 

2. Fill it with related but non-essential information 

3. Use a different font or background to distinguish it 

4. Position it at the edge of the page 

Image Frames 

Image frames specifically contain pictures, photos, or graphics. 

Example 3: Product Showcase For a product catalog: 

1. Create multiple image frames of consistent size 

2. Import product photos, cropping them appropriately 

3. Arrange frames in a grid pattern 

4. Add captions below each frame 

Example 4: Before/After Comparison For a home renovation article: 

1. Create two adjacent image frames 
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Notes 2. Import "before" and "after" photos 

3. Apply identical frame dimensions for proper comparison 

4. Add subtle borders to both frames 

Frame Properties and Formatting 

Border Styles 

Example 5: Decorative Certificate Border when creating a certificate: 

1. Insert a large frame covering most of the page 

2. Apply a thick, ornate border style 

3. Set the fill to transparent or light color 

4. Place text and logos inside the frame 

Example 6: Photo Gallery with Varied Borders For a creative 

portfolio: 

1. Create multiple image frames 

2. Apply different border styles to each (dotted, dashed, solid) 

3. Vary border weights for visual hierarchy 

4. Use complementary colors that match your photos 

Text Wrapping 

Example 7: Newsletter Layout For a professional newsletter: 

1. Place an image frame in the middle of text 

2. Set text wrapping to "Square" 

3. Adjust wrap distance to create comfortable spacing 

4. Align the frame to the right or left margin 

Example 8: Technical Document with Diagrams For engineering 

specifications: 

1. Insert technical diagrams as image frames 

2. Set text wrapping to "Top and Bottom" for clear separation 

3. Add captions that don't wrap around the image 

4. Maintain consistent spacing between text and diagrams 

Advanced Frame Techniques 

Linking Frames 

Example 9: Multi-page Article For content that continues across 

pages: 

1. Create text frames on each page 

2. Link them sequentially 

3. Pour text into the first frame 

4. Text automatically flows to subsequent frames when one fills 

up 
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Notes Example 10: Create a Table of Contents For a lengthy document: 

1. Create a frame on a dedicated TOC page 

2. Link it to hidden frames if needed for overflow 

3. Generate table of contents within these frames 

4. Apply special formatting to distinguish heading levels 

Anchoring Frames 

Example 11: Floating Annotations For research papers: 

1. Create small text frames for annotations 

2. Anchor them to specific words or paragraphs 

3. Set position to always appear in margins 

4. Apply consistent formatting to all annotation frames 

Example 12: Moving Diagrams with Text For technical 

documentation that undergoes frequent revision: 

1. Insert diagram as an image frame 

2. Anchor it to a specific paragraph 

3. Set appropriate text wrapping 

4. When the paragraph moves during edits, the diagram follows 

2.2.2 Working with Clipart 

 

Clipart consists of pre-made illustrations that can be inserted into 

documents to enhance visual interest. 

Finding and Inserting Clipart 

Built-in Libraries 

Example 13: Educational Worksheet For elementary school teachers: 

1. Open the clipart gallery in your application 

Fig 2.4 Working with clip art 

[Source: https://www.onlyoffice.com] 
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Notes 2. Search using keywords like "science" or "animals" 

3. Select age-appropriate illustrations 

4. Insert them next to related questions or content 

Example 14: Business Presentation For corporate slides: 

1. Access the built-in clipart collection 

2. Filter for business-related icons 

3. Select professional, minimal designs 

4. Insert consistently styled icons for each talking point 

Online Resources 

Example 15: Community Newsletter For a neighbourhood 

publication: 

1. Visit free clipart websites like Open Clipart or Pixabay 

2. Search for seasonal or community-themed illustrations 

3. Download appropriate files (preferably vector formats) 

4. Insert and resize while maintaining aspect ratio 

Example 16: Health Pamphlet For a medical office: 

1. Access specialized medical clipart collections 

2. Select anatomically accurate illustrations 

3. Download in high resolution 

4. Insert with proper attribution if required 

Modifying Clipart 

Recoloring 

Example 17: Holiday-Themed Documentation For seasonal business 

documents: 

1. Insert relevant holiday clipart 

2. Ungroup the clipart elements (if permitted) 

3. Change colors to match company branding 

4. Regroup modified elements 

Example 18: School Spirit Materials For educational institutions: 

1. Insert generic academic clipart 

2. Modify colors to match school colors 

3. Apply consistent color scheme across multiple pieces 

4. Save customized versions for future use 

Combining Elements 

Example 19: Custom Logo Creation For a startup: 

1. Insert several simple clipart elements 

2. Ungroup and delete unnecessary parts 

3. Combine remaining elements into a cohesive design 
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Notes 4. Save as a new graphic for consistent use 

Example 20: Instructional Sequence For a how-to guide: 

1. Insert several related clipart pieces 

2. Arrange them in process order 

3. Add connecting arrows between steps 

4. Number or label each component 

Clipart Best Practices 

Consistency 

Example 21: Employee Handbook For corporate documentation: 

1. Select clipart from the same collection/style 

2. Apply consistent sizing throughout the document 

3. Use a limited color palette that matches branding 

4. Position clipart in predictable locations 

Example 22: Children's Activity Book For educational publishers: 

1. Choose clipart with similar artistic style 

2. Maintain consistent character designs across pages 

3. Apply uniform scaling to all related elements 

4. Use similar color treatments throughout 

Appropriate Usage 

Example 23: Professional Resume For job seekers: 

1. Use minimal, professional icons only 

2. Select clean, simple designs for contact information 

3. Apply subtle colors that don't overwhelm text 

4. Ensure proper alignment with text elements 

Example 24: Academic Presentation For university lectures: 

1. Select conceptually relevant clipart 

2. Avoid cartoonish or juvenile illustrations 

3. Use clipart sparingly as visual aids 

4. Ensure clipart adds value rather than distraction 

2.2.3 Working with Pictures 

Pictures include photographs, screenshots, and other raster or vector 

images imported from external sources. 

Inserting Pictures 

From Files 

Example 25: Real Estate listing For property marketing: 

1. Take high-quality photos of the property 

2. Insert images via Insert > Picture > From File 

3. Select multiple photos for batch insertion 
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Notes 4. Arrange in order of exterior to interior shots 

Example 26: Product Manual For consumer goods: 

1. Prepare professional product photographs 

2. Insert at appropriate points in the instruction sequence 

3. Ensure consistent resolution across all images 

4. Match image size to importance of the step 

From Online Sources 

Example 27: Travel Blog For vacation documentation: 

1. Access stock photo sites like Unsplash or Pexels 

2. Search for relevant location images 

3. Download high-resolution options 

4. Insert with proper attribution 

Example 28: Current Events Report For a classroom assignment: 

1. Search news media sites for relevant images 

2. Verify usage rights before downloading 

3. Insert with citations and sources 

4. Size appropriately for page layout 

Picture Formatting 

Basic Adjustments 

Example 29: Photo Essay For a literary magazine: 

1. Insert high-quality photographs 

2. Adjust brightness and contrast for consistency 

3. Apply subtle color correction to unify visual theme 

4. Crop to emphasize important elements 

Example 30: Technical Documentation For software instructions: 

1. Insert screenshots of the application 

2. Crop to focus on relevant interface elements 

3. Add brightness to enhance readability 

4. Apply subtle border for separation from text 

Artistic Effects 

Example 31: Creative Marketing Materials For a brand campaign: 

1. Insert product images 

2. Apply artistic filters like watercolor or pencil sketch 

3. Adjust effect intensity for balance 

4. Maintain consistency across all images 

Example 32: Memory Book For a family celebration: 

1. Insert personal photographs 

2. Apply sepia or black-and-white effects to historical photos 
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Notes 3. Use vignette effects for nostalgic feel 

4. Balance between artistic and natural looks 

Advanced Picture Techniques 

Compression and Optimization 

Example 33: Email Newsletter For digital distribution: 

1. Insert necessary images 

2. Apply compression to reduce file size 

3. Use format appropriate for web (JPEG, PNG) 

4. Preview to ensure quality remains acceptable 

Example 34: Print Publication For commercial printing: 

1. Insert high-resolution images (300 DPI minimum) 

2. Check color space (CMYK for print) 

3. Balance quality and file size 

4. Export in appropriate format for printer requirements 

Picture Styles and Templates 

Example 35: Corporate Annual Report For shareholders: 

1. Define consistent picture style (border, shadow, reflection) 

2. Create a template with placeholder image frames 

3. Apply style automatically to all inserted images 

4. Ensure all team photos have identical treatments 

Example 36: Wedding Album For personal documentation: 

1. Select complementary frame designs 

2. Create master pages with picture placeholders 

3. Apply consistent corner rounding or frame effects 

4. Use theme colors for borders that complement photos 
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Notes Unit 2.3: Formula Tab 

 

2.3.1 Formula Tab 

The Formula tab provides tools for creating and editing mathematical 

equations and formulas within documents. 

Basic Formula Creation 

Simple Equations 

 

Example 1: Mathematics Homework For student assignments: 

1. Navigate to the Formula tab 

2. Select "New Equation" 

3. Enter algebraic equation like: x^2 + 2x + 1 = 0 

4. Format size and alignment to match surrounding text 

Example 2: Physics Reference Sheet For classroom use: 

1. Access equation editor from the Formula tab 

2. Create fundamental equations like F = ma 

3. Format with proper spacing between elements 

4. Group related formulas together 

Mathematical Symbols 

Example 3: Statistics Report For data analysis: 

1. Open the Formula tab 

2. Insert statistical symbols like σ (sigma) for standard deviation 

Fig 2.5: Basic Formula 

[Source: https://www.microsoftExcel.com] 
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Notes 3. Create probability expressions with proper notation 

4. Ensure consistent symbol sizing throughout 

Example 4: Chemistry Lesson Plan For science education: 

1. Access symbols library in the Formula tab 

2. Insert chemical equations with proper subscripts and 

superscripts 

3. Use reaction arrows and state symbols 

4. Format for clarity and educational standards 

Complex Formulas 

Multi-line Equations 

Example 5: Mathematical Proof For academic papers: 

1. Open the equation editor via Formula tab 

2. Create a step-by-step equation with multiple lines 

3. Use proper alignment for equal signs 

4. Number equations for reference 

Example 6: Engineering Calculations For technical documentation: 

1. Create a complex formula with the equation editor 

2. Use fraction structures for clarity 

3. Apply proper grouping with parentheses and brackets 

4. Include units in a consistent manner 

Matrices and Arrays 

Example 7: Linear Algebra Tutorial For mathematics instruction: 

1. Select matrix template from Formula tab 

2. Define dimensions (3×3, 2×2, etc.) 

3. Enter values with proper spacing 

4. Add operation symbols between matrices 

Example 8: Computer Science Documentation For algorithm 

explanation: 

1. Create arrays using bracket notation 

2. Insert proper indexing with subscripts 

3. Format for code-like presentation 

4. Add annotations explaining array operations 

Formula Integration 

In-line Formulas 

Example 9: Scientific Paper For academic publishing: 

1. Position cursor where formula should appear 

2. Access Formula tab and select "Inline Equation" 

3. Create compact notation like E=mc² 
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Notes 4. Adjust baseline to align properly with text 

Example 10: Economics Textbook For educational publishing: 

1. Write explanatory text 

2. Insert inline formulas for concepts like elasticity 

3. Maintain consistent size relative to text 

4. Use variables that match textual references 

Display Formulas 

Example 11: Mathematics Textbook For educational content: 

1. Create a new paragraph 

2. Access Formula tab for display equation 

3. Create centered, larger equation 

4. Add equation number in margin for reference 

Example 12: Research Proposal For grant applications: 

1. Insert display formula after explanatory paragraph 

2. Format with proper spacing above and below 

3. Create complex notation with multiple levels 

4. Reference the equation in subsequent text 

Formula Libraries and Templates 

Using Built-in Formulas 

Example 13: Physics Lab Report For student assessment: 

1. Access Formula tab's library 

2. Browse physics category 

3. Select relevant equations like the Schrödinger equation 

4. Customize variables as needed 

Example 14: Financial Analysis For business reports: 

1. Open formula library 

2. Select financial formulas section 

3. Insert time value of money equations 

4. Adapt parameters to specific analysis 

Creating Custom Libraries 

Example 15: Department Style Guide For academic consistency: 

1. Create commonly used equations in your field 

2. Save each to a custom formula library 

3. Organize by topic or complexity 

4. Share library file with colleagues 

Example 16: Student Reference Sheet For examination preparation: 

1. Compile essential formulas for a specific course 

2. Save as a custom formula library 
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Notes 3. Organize by Module or concept 

4. Distribute to students for consistent notation 

 

Integration Techniques 

Combining Frames, Clipart, and Pictures 

Layout Design 

Example 17: Magazine Spread For publishing: 

1. Create text frames for main article 

2. Insert picture frames for photographs 

3. Add decorative clipart elements for section breaks 

4. Balance all elements with consistent spacing 

Example 18: Informational Brochure For public outreach: 

1. Establish grid-based layout with frames 

2. Insert relevant photographs in image frames 

3. Add supporting clipart for visual interest 

4. Create text boxes with clear hierarchy 

Thematic Consistency 

Example 19: Company Profile For investor relations: 

1. Select corporate color scheme 

2. Apply to frame borders and backgrounds 

3. Choose clipart with compatible styling 

4. Process photos to match overall color palette 

Example 20: Educational Poster For classroom display: 

1. Choose theme-appropriate clipart 

2. Add supporting photographs 

3. Create text frames with relevant information 

4. Use consistent visual language across all elements 

Adding Formulas to Visual Elements 

Annotated Diagrams 

Example 21: Engineering Schematics For technical documentation: 

1. Insert technical drawing in an image frame 

2. Add text frames for labels 

3. Include formula objects for relevant calculations 

4. Connect elements with arrows or lines 

Example 22: Physics Demonstration For educational materials: 

1. Insert photograph of experimental setup 

2. Add text frames explaining components 

3. Include formula showing relationship between variables 
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Notes 4. Create visual connection between formula and physical 

elements 

Interactive Documents 

Example 23: Digital Textbook For e-learning: 

1. Insert diagrams in frames 

2. Add formulas as hoverable elements 

3. Link visual elements to explanatory text 

4. Ensure all elements are properly anchored 

Example 24: Technical Presentation For conferences: 

1. Create slide with key diagram 

2. Add sequential formula reveals 

3. Ensure formulas appear at appropriate moments 

4. Maintain visual connection between formulas and images 

Document Templates with Integrated Elements 

Corporate Templates 

Example 25: Company Report Template For consistent branding: 

1. Create master pages with logo in image frame 

2. Add header/footer text frames 

3. Define placeholder frames for content 

4. Include guideline layers for consistent placement 

Summary : 

This module focuses on data organization, analysis, and 

computation using spreadsheets. It begins with an introduction to 

spreadsheet basics, including cells, rows, columns, and worksheets. 

Learners are introduced to the Insert tab, which allows embedding 

tables, charts, images, and other visual aids for better data 

representation. The Formula tab is also explored, covering functions, 

formulas, and logical operators for calculations and data analysis. 

Students learn to apply mathematical, statistical, and logical 

functions, enabling problem-solving through dynamic formulas. By 

completing this module, learners understand how to efficiently 

manage data, perform calculations, and create visually appealing 

reports using spreadsheet tools. 

 

MCQs: 

1. What is the default file extension of a Microsoft Excel 

spreadsheet? 

a) .docx 

b) .xlsx 
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Notes c) .pptx 

d) .txt 

Ans a) 

2. Which symbol is used for formulas in a spreadsheet? 

a) @ 

b) # 

c) = 

d) & 

Ans c) 

3. A cell in a spreadsheet is identified by: 

a) A number 

b) A row label 

c) A column label 

d) A row and column label (e.g., A1) 

Ans d) 

4. How do you insert a new row in Excel? 

a) Right-click a row number → Insert 

b) Click on Home → Delete 

c) Select column → Insert 

d) Press Ctrl + R 

Ans c) 

5. What is the function of the Formula Tab in spreadsheets? 

a) Formatting text 

b) Performing calculations 

c) Inserting images 

d) Changing font size 

Ans b) 

6. What happens when you press Ctrl + S in a spreadsheet? 

a) Sorts data 

b) Saves the file 

c) Inserts a new row 

d) Opens a new sheet 

Ans  b) 

7. The SUM() function is used to: 

a) Count the number of cells 

b) Find the total of a range of numbers 

c) Convert text to numbers 

d) Merge two columns 
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Notes Ans  b) 

8. In Excel, A1:C3 represents: 

a) A single cell 

b) A row 

c) A range of cells 

d) A column 

Ans  c) 

9. Which of the following is NOT a valid data type in a 

spreadsheet? 

a) Text 

b) Number 

c) Image 

d) Date 

      Ans  c) 

10. What feature allows you to apply the same formula to 

multiple cells? 

a) Copy-Paste 

b) AutoFill 

c) Merge 

d) Split 

         Ans a) 

Short Questions: 

1. What is a spreadsheet? Give examples of its applications. 

2. How do you open and save a spreadsheet file? 

3. Explain spreadsheet addressing with an example. 

4. What is the difference between a row and a column in a 

spreadsheet? 

5. How do you insert a new column and row in Excel? 

6. What are the different types of data that can be stored in a 

spreadsheet? 

7. How can you insert an image in a spreadsheet? 

8. What is the purpose of the Formula Tab in a spreadsheet? 

9. Explain the function of cell referencing in Excel. 

10. What is the AutoFill feature in spreadsheets? 

Long Questions: 

1. Explain the concept and importance of spreadsheets in data 

management. 

2. Discuss different cell addressing methods with examples. 
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Notes 3. Write the steps to insert, delete, and format data in Excel. 

4. What is the difference between absolute, relative, and mixed 

cell references? 

5. Explain the use of formulas and functions in spreadsheets with 

examples. 

6. Write a program in Excel to calculate the total and average 

marks of students. 

7. How do you insert external files like images, clipart, and 

charts into a spreadsheet? 

8. Discuss how a spreadsheet can be used for budgeting and 

financial planning. 

9. What are the common spreadsheet errors, and how can they be 

corrected? 

10. Explain the importance of formatting tools in Excel for data 

visualization. 
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MODULE 3 

PRESENTATION 

 

LEARNING OUTCOMES 

By the end of this Module, students will be able to: 

• Understand the basics of presentation software and its 

applications. 

• Learn how to create, open, and save a presentation. 

• Understand different presentation layouts. 

• Learn how to add and format text in a presentation. 

• Understand how to insert headers, footers, and slide layouts. 

• Learn how to add graphics, animations, and transition effects 

to slides. 
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Notes Unit 3.1: Introduction to Presentation 

 

3.1.1 Introduction to Presentation: Opening New Presentation 

The Power of Presentations: A Modern Communication Tool 

Effective communication is a skill key in the modern world. Broader 

than just academia or the corporate boardroom or a barbeque the 

difference a good presentation makes is undeniable Gone are the days 

of basic drugs and the new industry standard is dynamic interactive 

experiences that captivate audiences and produce action. They are a 

fundamental way to convey information, share ideas, and persuade 

others. A successful presentation is about more than slides it’s a 

narrative, a message that resonates with the audience. While many 

people still think of presentations as "Death by PowerPoint," in the 

digital age, presentations have become a multimedia experience that 

can touch the lives of many others all around the world or be simply 

buried in front of a bunch of disinterested faces thanks to tools like 

Microsoft PowerPoint, Google Slides, and Apple Keynote that offer 

features that create gorgeous and stunning presentations. There are 

important in many fields. They make sharing possible in the world of 

education by helping your educators convey complicated topics in a 

more easily digestible medium. In business, they are deployed for 

pitching ideas, progress updates and employee training. They 

supplement the speaker’s message visually and reinforce key concepts 

from the presentation. It is mainly an exercise in how well you can 

engage an audience and keeps their attention. Use the design of your 

slides as inspiration for the structure of your presentation, be sure to 

make it as visual as possible and then deliver it with confidence. Your 

content must be audience specific to their needs and interests. The 

use of multimedia elements such as images, videos and animations 

can also increase engagement and understanding, in the end. 

Presentation training will help individuals again convey their ideas 

well because at its very basics with · The presentations are a powerful 

form of communication, a strong agent of persuasion, and a means of 

knowledge transfer where individuals and organizations present their 

plans, products, and concepts in the hope of reaching their goals. 

Knowing the Presentation Ecosystem: Software and Resources 

You may be surprised by just how many choices are available, 

whether you go for standalone presentation software, or an add-on for 
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Notes another application. Understanding of these tools will allow you to 

select the right one for yourself! Microsoft PowerPoint, the corporate 

world’s de facto program, is the gold standard for an array of features 

and powerful capabilities. It has lots of templates, animations and 

transitions, which allows users to create a visually advanced 

presentation. Its online counterpart, Google Slides, provides the 

benefit of real time collaboration and access from any device. This 

also allows for collaboration since multiple people can access the 

same document at the same time and is great for teamwork projects. 

It is simple, beautiful and most used tool for graphic designer. But 

outside of these major offerings there are a few other tools worth 

thinking about. (For example, Prezi has a different zooming interface 

with which users can build presentations non-linearly.)  

 

Haiku Deck is a visually-oriented minimal presentation tool with 

good articulation. Canva is a design platform with thousands of 

templates and design elements to help you create brilliant 

presentations effortlessly. It may though, at least I guess, which 

presentation software to be used, ultimately depends on who the user 

is, who the audience is and what the goal of the presentation is. Your 

corporate presentation would probably take advantage of the 

hallmarks of PowerPoint but a creative presentation would showcase 

the aesthetics of Keynote. Regardless of which of these platforms you 

choose, though, the basic principles of good presentation design are 

Figure 3.1:  Power Point Example 

[Source: https://www.vskills.in] 
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Notes the same. Therefore, presentations need to be designed in the true 

sense of the word, using clarity, and conciseness and visually enticing 

with the engagement of the audience to achieve the desired result. 

Step One: Create a New Presentation 

When you set out to make a great presentation, it all begins with a 

new file. This initial stage paves the way for the art of creation, 

offering a clean slate for ideas to manifest as visual stories. How to 

Open New Presentations on Different Software The process of 

opening new presentations varies a little depending on the software 

you are using, but the same principles underlie them. 

Microsoft PowerPoint: A Detailed Walkthrough 

Microsoft PowerPoint, a ubiquitous tool in the presentation world, 

offers a straightforward method for opening new files. 

Launching PowerPoint: 

Step 1: Go to the PowerPoint application. You can open the 

PowerPoint program by clicking on the PowerPoint icon on the 

desktop, in the Start menu, or in the applications folder. For example; 

you are at your computer to create a presentation for a project 

proposal. You find the PowerPoint icon on your desktop, a stylized 

“P” set against an orange backdrop, and double-click it. The 

application starts and shows the start screen. 

Navigating the Start Screen: 

When you first start PowerPoint, it will bring up a start screen with 

several different options, including recent presentations that you’ve 

worked on or templates you can use, or you can create a blank 

presentation. 

Example: On the PowerPoint start screen, you see a list of recently 

opened files on the left. In the center, there are various template 

thumbnails, ranging from business presentations to photo albums. At 

the top, a large thumbnail reads "Blank presentation," inviting you to 

begin your creation. 

Choose Blank Presentation: 

Click on the "Blank presentation" option to create a new presentation 

from scratch. Doing so will create a new, blank presentation in your 

default slide layout. For example, when you move your mouse cursor 

above the "Blank presentation" thumbnail and click. A new window 

opens, with a single slide and placeholders for a title and a subtitle. 

This is your blank canvas. 
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Notes Using Templates: 

Or you can select from a huge selection of templates that are pre-

designed, to help you get your presentation started. They provide a 

variety of layouts, color schemes, and overall design elements right 

off the bat. For example, instead of looking at a blank presentation 

you decide to search templates. You select a “More themes” option 

and scroll through a gallery of templates. You see a template called 

Modern Business Proposal with a clean blue and gray design. You 

press it and then press “Create.” The new presentation opens, filled 

with sample slides based on the selected template. 

3.1.2 Keyboard Shortcuts: 

You can open new presentation with keyboard shortcuts for 

efficiency. To do this, press Ctrl + N to open a new, blank 

presentation. 

Example: You then close the current PowerPoint window and open 

the application. You press Ctrl + N on the keyboard instead of clicking 

through the mouse. A new empty presentation opens immediately. 

Google Slides: A Cloud-Based solution 

It is a cloud-based presentation tool, so google slides provide smooth 

and collaborative way of creating presentations. 

Accessing Google Slides: 

Google Slides can be used in a web browser. Navigate to slides. 

google. Visit docs.google.com or open it from your Google Drive. 

For example, you open your favorite web browser, enter "slides. 

google. Enter “https://www.netflixtvshows.com” in the address bar 

and click Enter. The Google Slides interface loads; it shows your 

existing presentations and options for creating new ones. 

Creating a New Presentation: 

Click on the “+ (plus)” icon or the “Blank” option to add a new blank 

presentation. For example, you see a big “+” icon stating “Blank” at 

the Google Slides interface. You click on it and a new browser tab 

opens up, showing you a new blank presentation. 

Using Templates: 

Google Slides also has its set of templates. You will see “Template 

gallery” click that to view templates and choose one. Instead of 

starting a new blank presentation, you click on “Template gallery” in 

the top right corner of the Google Slides UI, for example. A slider 

flies out, presenting various templated categories. You apply a filter 
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Notes for this search to the category “Business” and select a template called 

“Project Proposal.” You choose it and then a brand-new presentation 

opens, in its layout and design. 

Google Drive Integration: 

If you use Google Drive, the Google Slides app integrates very well. 

You you agree to create new presentations simply by clicking on 

“New” Google Drive and choosing “Google Slides.” For example; 

You open a new browser tab with Google Drive. You click on “new,” 

scroll down to “Google Slides” and click “Blank presentation.” You 

now open the New Google Slides presentation right in your Google 

Drive. 

On the other hand Apple Keynote also needs no citation. 

Features of Apple Keynote: Apple Keynote is known for its elegant 

design and intuitive interface. 

Launching Keynote: 

Open the Keynote program from your Applications folder or Dock. 

For example; You click the Keynote icon in your Dock a stylized 

podium icon and the application launches. 

Choosing a Theme: 

Keynote opens to a theme chooser with several preconfigured 

themes. Choose a theme to start a fresh presentation. Example; It 

brings up the Keynote theme chooser, offering thumbnails of all sorts 

of themes, from simple text-based to photo-dense layouts. You pick 

“Basic White” theme and hit “Choose.” A new presentation starts 

with a blank slide based on the chosen theme. 

Blank Theme Option: 

It is also possible to start with a blank theme by selecting the "Blank" 

theme option. For example, you scroll down on the theme chooser 

and pick "Blank" theme. You hit “Choose,” and a totally blank slide 

pops open, ready for you to customize. 

iCloud Integration: 

Keynote also integrates with iCloud, so you can generate and view 

presentations on any Apple device. For example; you launch Keynote 

on your iPad. The iCloud Drive folder shows any existing Keynote 

files you have. You tap the up-arrow (+) control at top right, and 

Keynote launches the theme chooser.  

3.1.2 Selecting Presentation Layout 
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Notes Have the ability to convey an idea through a presentation to influence 

others to procrastinate and accomplish their ambition. You will find 

that is also where aesthetics will come into play in not only a 

presentation but also a talk the content of that presentation is not the 

only thing that makes it successful. Imagine being a book author, the 

presentation layout is the architecture of the presentation that tells a 

story, a framework that makes flow of information, the visual 

structure that make reading a logical journey and finally the audience 

responses. Choosing the best Presentation Layout is not just a design 

question it’s a fundamental choice that could have a tremendous 

impact on your chances of landing your message. This Module digs 

into the nuances of what to bear in mind as you make different 

decisions about how to lay things out for presentation, spelling out the 

options available to you, the rules of thumb and things to ponder, to 

set your message up to succeed. 

Why Do You Need Presentation Layouts 

Here is my paraphrase you can use a presentation layout which is an 

already created template to organize content on your slides. They 

simplify, create an efficient design process and hold a consistent 

theme and visual appearance. A well-chosen layout can: 

• Increase Clarity: Logic in information organization makes for 

clearer message comprehension among the audience. 

• Keep It Consistent: Using a consistent layout across your slides 

creates a cohesive and professional presentation. 

• Tune the Aesthetic: Attractive layouts create interest and 

engagement within the audience. 

• Save Time: Pre-designed layouts help you avoid setting each 

slide up from scratch. 

• Focus Attention: Purposeful use of layouts guides the audience's 

focus. 

3.1.3 Different Layouts for Presentation and Where to Use 

Them? 

Presentation software offers a wide variety of layouts (e.g., Microsoft 

PowerPoint, Google Slides, and Keynote). There are several types of 

layouts, and knowing them is important to choose the right one for the 

content to be presented. 

Title Slide: 
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Notes • Purpose: Introduces the presentation and captures the 

audience's attention. 

 

• Basic elements: the title of the presentation, the presenter's 

name, date, and company logo. 

Example: For the topic "The Future of Artificial Intelligence," use a 

title slide to list the title, the presenter's name, institution, and 

anything else related to the talk. It could also include a striking image 

about the AI. 

Title and Content: 

• Purpose: Title with a bullet or paragraph of text. 

• Elements: Title of the slide and a text box. 

For instance, a slide entitled "Key Benefits" might include bullet 

points that would enumerate the benefits of a new product or service. 

3.3 Adding Text to a Presentation 

When creating a presentation, adding text is a crucial step to 

communicate key points effectively. Below are the steps to add text in 

common presentation tools like Microsoft PowerPoint, Google 

Slides, and Keynote: 

Fig 3.2: Adding Text 

[Source: https://www.vskill.in] 
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Notes  

Adding Text in Microsoft PowerPoint 

Using a Text Box 

1. Open PowerPoint and go to the slide where you want to add 

text. 

2. Click on the "Insert" tab in the top menu. 

3. Select "Text Box" from the toolbar. 

4. Click anywhere on the slide and start typing. 

5. Resize or move the text box as needed. 

Using Pre-Designed Slide Layouts 

1. Go to the "Home" tab. 

2. Click "Layout" and choose a slide with text placeholders. 

3. Click inside the placeholder and type your content. 

Adding Text in Google Slides 

1. Open Google Slides and select a slide. 

2. Click "Insert" in the menu bar. 

3. Select "Text Box" and click on the slide to create a text area. 

4. Start typing your content. 

5. Drag to resize or move the text box as needed. 

Adding Text in Apple Keynote 

1. Open Keynote and select the slide. 

2. Click "Text" from the toolbar. 

3. A text box will appear—click inside it to start typing. 

4. Drag the box to move it and use formatting tools to customize 

the text. 

Text Formatting Tips 

• Use bold, italics, and underlining for emphasis. 

• Maintain a clear font (e.g., Arial, Calibri, or Times New 

Roman). 

• Keep text concise—avoid too much text on a single slide. 

• Use bullets or numbering for better readability. 

3.1.4 Header and Footer 

• Purpose: This serves to introduce a new section or topic 

within your presentation. 

• Elements: Title of section, optional introductory text 

Example: Preceding a section with the header "Marketing Plan" 

before outlining marketing strategies provides context for a shift in 

topic. 
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Notes Two Content: 

• Function: Shows two pieces of information side by side, 

comparing or contrasting them. 

• Elements: Title of the slide and two contents. 

For instance, a slide titled "Traditional Marketing vs. Digital 

Marketing" may have bullet points or images in each content area. 

Comparison: 

• Purpose: Just like “Two Content,” but typically has an area 

for text in the center (to compare points). 

Slide Title, Two Content Areas, Center Text Area. The example owe 

the slide comparing two product features might have the features on 

the left and right in each content area, with the differences explained 

in the centre text area. 

Content with Caption: 

• Use: Name and Describe an Image/Image with Caption 

Slide Title, Media area and Caption area i.e., if it is a slide with 

product image, caption with i.e., key features or benefits. 

Picture with Caption: 

• Purpose: Primarily centers attention on one large image with 

one or two short captions. 

• Features: Large media area with small text caption area. 

Example: Slide featuring an impressive landscape photograph, with 

some text explaining where it was taken. 

Blank: 

• What is it: Offers an entirely empty template to create your 

layouts. 

• Elements: No predefined content areas. 

Example: For customized presentations with unique layouts or when 

you want to embed a video or interactive elements. 

Content with Smart Art: 

• Function: Displays information in a structured, attractive 

manner through Smart Art graphics. 

Title and Smart Art graphic 

Example: slide with an organizational hierarchy with a Smart Art 

organizational chart. 

Content with Chart: 

• Usage: Uses charts and graphs to visually present data. 

• Elements: Title and chart. 
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Notes Example: Sales data over the last 5 years, as a line chart on 1 slide. 

Lay Out Selection Best Practices 

Choosing an appropriate layout is about keeping a few key principles 

in mind as follows: 

Content Relevance: 

The layout must be able to support the content and make it easier to 

read. For example, if you are showing a lot of text, the layout you 

will use is a "Title and Content" If it is a comparison of two options, 

the appropriate layout would be a "Comparison" or "Two Content" 

layout. 

Audience Consideration: 

• Layout should meet expectations of users and their 

comprehension. 

Example: If the pitch is with technical audience then, the layout may 

be a bit more technical with charts and graphs For a non-specialist 

audience, simpler layouts with visuals are more effective. 

Visual Hierarchy: 

The design should lead the eye of the audience to the most important 

information. Illustration; Eg: Write the fonts of Heading and key take 

away points in big fonts; keep the important data/ information in 

contrasting colored fonts. 

Consistency: 

• Use consistent layouts throughout the presentation to achieve 

a coherent and professional appearance. 

Example: Keep the font styles, colors, and layout patterns consistent 

on all slides. 

Simplicity: 

• Reduce clutter so the message stands out I know there are 

beginner users in your community. 

Example: Make use of white space to give breathing room to visuals 

and not overcrowd a slide with text or visuals. 

Visual Appeal: 

Employ visually attractive designs to attract the crowd and retain their 

attention Do; Use visually appealing and high-quality 

images/relevant graphics/a consistent color scheme. 
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Notes Unit 3.2 : Slide Layout 

 

3.2.1 Slide Layout 

In addition to the principles, many practical considerations drive 

layout choice: 

Presentation Purpose: 

Depending on the kind of use that the presentation will be used for, 

you will need different layouts. For example, sales presentations need 

to be more visually aesthetic layouts with product images and graphs, 

while educational presentations may be more text-related with bullet 

points. 

Time Constraints: 

The duration granted for designing the presentation affects the 

intricacies of the layouts. e.g. When there is limited time, pre-

designed layouts and templates can reduce time significantly. 

Software Capabilities: 

Choose presentation software whose features and capabilities affect 

the layout options. For instance; PowerPoint comes with very 

beautiful templates and lots of customizing things, whereas others 

come with limited options. 

Branding Guidelines: 

Follow branding guidelines (colours, fonts, and logos) if you are 

presenting on behalf of an organisation. Example; Presenting in the 

organization’s official colour palette and logo 

Accessibility: 

Make sure that layouts can be navigated by all members of the 

audience including those with visual impairments. For example, high 

contrast colors, alternative text for images, and clear and concise 

language. 

A Quick Guide to Choosing a Layout 

Define the Purpose: 

Identify the purpose of the presentation and the main messages to be 

communicated. Example; to convince the investors to invest in the 

new potential project. 

Outline the Content: 

Outline the presentation with the main points and supporting details. 

For example; executive summary, market analysis, product 

description, financial projections, conclusion 
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Notes Choose a Template (Optional): 

Choose a template that matches the nature of the presentation and the 

brand guidelines. For example; A company template for a corporate 

presentation. 

Choose Layouts For Each Slide: 

Using the principles and practical considerations outlined previously, 

select layouts that are best suited to the content of the slides; For 

example, the title slide for introduction could be “Two Content” for 

comparing the array of options “Content with Chart” for financial 

projections 

Customize the Layouts: 

Customize the layouts accordingly to accommodate the content and 

improve aesthetics. Example; adjusting font sizes, inserting images 

and changing color. 

Review and Refine: 

Check the presentation helped the story stay clear, and layouts that 

feel tight Check for typos, resize the images, and see that the special 

formatting across all of them is similar. 

3.2.2 Slide Layout  

Introduction: The Text — the Building Block of Communication 

As with any design, text is the base underlying element with 

presentations; it is the layer on which everything else depends. Great 

visuals, animations and multimedia attract attention, but it is the 

carefully worded text that conveys the core message, lays out the 

significant details, and propels the audience’s initial understanding. 

What I mean is in the presentations, they are not just words in the 

screen, it should conveys the message clearly and appropriately. 

When used correctly, text can elevate a simple pitch or proposal into a 

believable, sensational news story, winning sales pitch, or lesson in 

two-way tutoring. In this Module, we will learn and go through the art 

and design behind adding text in your presentations, common 

techniques, best practices and examples that will enable you to 

maximize impact and create powerful and memorable content. 

Basic principles of putting text into presentation software 

Presentation software including Microsoft PowerPoint, Google Slides 

and Apple Keynote generally includes fairly intuitive tools for adding 

and manipulating text. Those fundamentals will guide you in the right 

direction when you start creating your slides. 



 

69 
 

Notes • Text Boxes: 

You can add text only using text boxes. These are boxes that let you 

type, format, and place text in any way you want on a slide. For 

example, if you are creating a PowerPoint presentation, you may 

insert a text box on the slide by selecting “Insert” from the top vertical 

toolbar menu and clicking “Text Box.” Then click and drag on the 

slide to create the box and start typing. Best Practice; Separate 

specific blocks of information using text boxes such as titles, bullet 

points, captions, etc. This provides you with fine granularity with 

respect to the placement and formatting. 

• Placeholders: 

Each of the slide layouts provides built-in placeholders for titles, 

subtitles, and content. Using placeholders provides an easier way of 

incorporating text, since they are already aligned and formatted. For 

instance, if you choose a "Title and Content" slide layout, 

placeholders for both the title and the content will automatically be 

created.  Best Practice; Use placeholders, which are empty templates 

for standard slide elements to ensure uniformity in formatting and 

layout throughout your presentation. 

• WordArt: 

 

Fig 3.3: Word Art 

[Source: https://www.vskill.in] 
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Notes Presentation programs have WordArt or equivalent for decorative or 

stylized text. These tools enable you to add multiple effects like 

shadows, gradients, and 3D transformations. Example; PowerPoint > 

Insert the WordArt. Select a style, and type your text. Best Practice; 

Use WordArt in moderation; using too much can look busy on the 

page. Use it for titles or key phrases that need to stand out. 

Putting Text into a Shape: Emphasis and Expansion 

How text looks on a digital page is vital to its legibility and 

effectiveness. Good formatting improves readability and draws 

attention to important items. 

• Font Selection: 

Choose fonts that are clear, legible and appropriate for your audience 

and topic. Steer clear of too ornate or elaborate fonts that can be hard 

to read. Ex; Use only sans-serif font like Arial, Calibri, Helvetica for 

body text, and only Serif font such as Times New Roman, Garamond 

for titles. Best Practice; Try not to use more than two or three types of 

fonts in your presentation for intact consistency and avoiding visual 

clutter. 

• Font Size: 

Use large Font size for best readable from distance. Think about the 

size of the room and the viewers’ eyesight. Example; Titles = 28-44 

points, Body text = 18-24 points Best Practice; Check visually for full 

screen and other projection modes in the real space to make sure all 

text is clear to all viewers. 

• Font Color: 

Select font colors with enough contrast to the background. Make sure 

the text is a color that contrasts with the background, not to similar or 

hard to read. Example; Stick with dark on light or light on dark Best 

Practice; Use color wisely, for example, to emphasize the most 

critical points, or to add visual variety. However, don't use these too 

many colors, because it can prove to be disruptive. 

• Text Alignment: 

Use uniform text alignment for a polished and professional 

appearance. Nonetheless, body text is generally better left aligned 

while center alignment is fine for titles. Example; Set the bullet points 

to align left so they can be read easily. {Center Align slide title for 

emphasis} Best Practice; do not use justified alignment because it 

creates uneven spacing between words which can be hard to read. 
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Notes • Line Spacing: 

Edit line spacing for better visual clarity. Line Spacing – Keep 

enough space between each line so the text does not come off 

cramped. I.e. standardize line spacing to 1.15 or 1.5 for body text. 

Best Practice; Try multiple line spacing settings to see which works 

best for you. 

• Emphasis: 

Highlight important words or phrases in bold, italics or underlined. 

These effects should be used sparingly, since overuse would lead to 

diminish the impact of such an effect. Examples of different style 

tags; Use to highlight key terms or phrases. Italicize quotations or 

foreign words. Best Practice; Don’t use ALL CAPS to emphasise 

something, it looks angry or shouty. 

Focus on Content: Strive For Clarity And Brevity 

The image of your text matters as much as it’s content. Harness the 

Conversational Skills to Connect with Your Audience 

• Keep it Brief: 

Do not fill the slide with excessive text and over crow the slides. Be 

brief, bullet points, short phrases and keywords are better. Example’ 

Write “Financial performance: Significant improvement,” instead of 

“The company's financial performance has shown a significant 

improvement in the last quarter.” Best Practice; Adhere to the “6x6 

rule”: no more than six bullet points on a slide and no more than six 

words on a bullet point. 

• Use Keywords: 

Determine the most important messages and concepts Read More 

These points reinforce them with keywords. Use key words related to 

your topic, as an example if your presentation is about marketing 

relevant words could be “target group”, “awareness of the brand”, etc. 

Best Practice; consistently reuse keywords throughout your 

presentation to echo your message. 

• Tell a Story: 

Build your content to have a great story. Narrate your message so 

that your readers will relate and memorise it. for example: problem 

statement → solution → results Use storytelling techniques, such as 

anecdotes, examples, and metaphors, to make your presentation more 

engaging. 

• Use Active Voice: 
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Notes Sharpen your writing with active voice. Active voice and passive 

voice in a sentence Example; Active voice instead of "The team 

submitted the report" vs. "The report was submitted by the team" 

Active voice is mostly more concise and easier to read than passive 

voice, which is as follows:  

• Use Parallel Structure: 

Use parallel structure to provide balance and rhythm in the writing. 

That is parallel structure, which means using the same grammatical 

form through related words, phrases or clauses. For Example; Don't 

say "The team is responsible for planning, execution, and to report on 

the project" write "The team is responsible for planning, executing, 

and reporting on the project." Best Practice; Parallel guidelines 

improves readability and makes your writing more persuasive. 

Techniques for achieving Basic Text Basic Text 

If you want to go further, several advanced techniques can help you 

create visually pleasing, impact text. 

• Text Animations: 

Use of text animations to progressively reveal text or in highlighting 

key points or creating visual interest Use animations in moderation, 

but be careful not to overdo it, as it spreads distractions. Example; 

Use a “Fade In” animation to show bullet points sequentially. Best 

Practice; Use subtle, professional animations. Do not make annoying 

animations or baggy animations. 

• Text Transitions: 

Use the text transitions to ensure a smooth transition between slides. 

This also helps with the flow and keeping the audience engaged. If 

you want to "Push" one text to second slide. Best Practice; Select 

transitions that suit the content and tone of your presentation. 

• Smart Art Graphics: 

Smart Art graphics for a visual overview of information like 

processes, hierarchies, or relationships. Smart Art graphics help to 

present dense information in a concise and dynamic manner. 

Example; Demonstrate the steps of a project with a “Process” Smart 

Art graphic. Best Practice; Select Smart Art graphics that suit the data 

to be represented. 

• Text with Images: 

Using text and images together to build appealing information slides 

Use images throughout to reinforce what you are saying and to create 
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Notes visual interest. Example; Overlay text on a relevant image to simplify 

and stylise a slide. Best Practice; Use relevant, high-quality images If 

you use images, make sure the text is readable on it. 
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Notes Unit 3.3 : Adding Graphics to the Presentation 

 

3.3.1 Adding Graphics to the Presentation, Setting Animation and 

Transition Effects 

1. Adding Graphics to a Presentation 

Graphics enhance a presentation by making it visually appealing and 

engaging. Here’s how to add graphics in different presentation tools: 

Microsoft PowerPoint 

1. Insert Images:  

• Click on the "Insert" tab. 

• Select "Pictures" → Choose "This Device" (for local 

files) or "Online Pictures". 

• Browse and insert the image. 

2. Insert Shapes & Icons:  

• Go to "Insert" → Click "Shapes" or "Icons". 

• Choose a shape/icon and place it on the slide. 

3. Insert Smart Art & Charts:  

• Select "Smart Art" for diagrams or "Chart" for data 

visualization. 

• Customize the inserted graphic. 

Google Slides 

1. Click "Insert" → "Image". 

2. Select an image from your computer, Google Drive, or the 

web. 

3. Adjust size and position. 

Apple Keynote 

1. Click "Media" → Select "Photos" or "Choose" to upload. 

2. Resize and position as needed. 

2. Setting Animation Effects 

Animations make elements (text, images, shapes) appear dynamically. 

Microsoft PowerPoint 

1. Select the object you want to animate. 

2. Click on the "Animations" tab. 

3. Choose an animation effect (e.g., Appear, Fade, Zoom, Fly In). 

4. Use "Animation Pane" to adjust timing and order. 

Google Slides 

1. Click on the object. 

2. Select "Animate" from the menu. 
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Notes 3. Choose the animation type and adjust speed. 

Apple Keynote 

1. Select the object. 

2. Click "Animate" → "Add an Effect". 

3. Choose the desired animation. 

3. Applying Slide Transition Effects 

Transitions control how slides move from one to another. 

Microsoft PowerPoint 

1. Click on the "Transitions" tab. 

2. Choose a transition effect (e.g., Fade, Wipe, Morph, Push). 

3. Adjust the duration and select "Apply to All" (if needed). 

Google Slides 

1. Click "Slide" → "Transition". 

2. Select a transition effect. 

3. Adjust speed and apply it to selected or all slides. 

Apple Keynote 

1. Select the slide. 

2. Click "Animate" → "Add a Transition". 

3. Choose an effect like Dissolve, Cube, or Flip. 

Summary : 

This module emphasizes effective communication through visual 

presentations. It begins with the introduction to presentation tools 

where learners explore slide-based software and its applications. The 

unit on slide layout introduces structured templates for organizing 

information. Learners then study techniques for adding graphics, 

including images, charts, multimedia, and animations, to enhance 

audience engagement. The module focuses on clarity, design 

consistency, and presentation flow. By its completion, students 

acquire the ability to create impactful, professional-quality 

presentations that combine textual, visual, and interactive elements to 

convey ideas effectively. 

MCQs: 

1. What is the default file extension of a Microsoft 

PowerPoint presentation? 

a) .pptx 

b) .docx 

c) .xlsx 

d) .pdf 

Ans a) 
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Notes 2. Which shortcut key is used to start a slideshow from the 

beginning? 

a) F2 

b) F5 

c) F12 

d) Ctrl + S 

Ans b) 

3. What is a slide layout? 

a) A predefined slide design 

b) A slideshow animation 

c) A transition effect 

d) A text box 

Ans a) 

4. Where can you find options to add headers and footers in 

PowerPoint? 

a) Insert Tab 

b) Design Tab 

c) File Tab 

d) View Tab 

Ans a) 

5. Which tab is used to add animations to slides? 

a) Insert 

b) Design 

c) Animation 

d) Transition 

Ans c) 

6. What does the Slide Master feature do? 

a) Creates animations 

b) Manages slide layouts and formatting for the entire 

presentation 

c) Adds images to slides 

d) Deletes slides 

Ans b) 

7. Which of the following is an example of a transition effect? 

a) Slide Zoom 

b) Fade 

c) Slide Text Box 

d) Bold Text 
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Notes Ans b) 

8. What is the purpose of the Notes Pane in PowerPoint? 

a) To add speaker notes 

b) To add slides 

c) To insert charts 

d) To add hyperlinks 

Ans  a) 

9. What is the use of the Rehearse Timings feature in 

PowerPoint? 

a) To check animations 

b) To set the timing for slideshows 

c) To edit text 

d) To insert audio 

Ans b) 

10. How do you insert a picture into a presentation? 

a) File → Add Picture 

b) Insert → Picture 

c) View → Picture 

d) Slide → Picture 

Ans b) 

Short Questions: 

1. What is a presentation? Give an example. 

2. How do you open and save a presentation? 

3. What are different slide layouts in PowerPoint? 

4. How do you insert a header and footer in a slide? 

5. What is the purpose of a Slide Master? 

6. How do you add text to a PowerPoint slide? 

7. What is the difference between animations and transitions? 

8. Explain the steps to insert images and clipart into a 

presentation. 

9. What is the purpose of the Rehearse Timings feature? 

10. How do you apply slide transitions in PowerPoint? 

Long Questions: 

1. Explain the importance of presentation software in business 

and education. 

2. Discuss the different slide layouts and their applications. 

3. How do you insert and format text in a PowerPoint 

presentation? 
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Notes 4. Explain the steps to add animations and transitions to slides. 

5. Write the steps to insert a header, footer, and slide number in a 

presentation. 

6. What is the role of images and graphics in a presentation? 

Explain with examples. 

7. Describe the Slide Master feature and how it helps in 

formatting slides. 

8. Explain the process of designing an effective PowerPoint 

presentation. 

9. How do you record and add audio narration to a PowerPoint 

slideshow? 

10. Write the steps to create and deliver a professional 

presentation. 
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MODULE 4 

HTML BASICS 

 

LEARNING OUTCOMES 

By the end of this Module, students will be able to: 

• Understand the basics of HTML and its importance in web 

development. 

• Learn about HTML elements and their attributes. 

• Understand how to use headings, paragraphs, and styles in 

HTML. 

• Learn about CSS and how to format tables in HTML. 

• Understand the use of HTML classes and IDs. 

• Learn how to create responsive web pages using HTML. 

• Understand the concept of HTML forms and their 

applications. 
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Notes Unit 4.1: Introduction to HTML 

 

4.1.1 Introduction to HTML, Elements of HTML 

Hypertext Mark-up Language (HTML) is the foundation of web 

development. It structures content on the web, allowing developers to 

create visually appealing and functional websites. Understanding 

HTML is crucial for any web developer, as it defines the layout and 

elements of a webpage. 

Importance of HTML in Web Development 

• Defines Web Structure: HTML provides the fundamental 

structure of web pages. 

• Compatibility: It works across all browsers and devices. 

• SEO Benefits: Proper HTML markup enhances search engine 

optimization. 

• Integration with Other Technologies: HTML integrates with 

CSS and JavaScript for dynamic and visually appealing 

designs. 

• Ease of Learning: It is beginner-friendly and easy to 

understand. 

HTML Basics 

HTML Document Structure 

An HTML document consists of elements enclosed within tags. The 

basic structure includes: 

<!DOCTYPE html> 

<html> 

<head> 

<title>My First Webpage</title> 

</head> 

<body> 

<h1>Welcome to My Website</h1> 

<p>This is my first webpage.</p> 

</body> 

</html> 

Explanation: 

• <!DOCTYPE html>: Defines the document type. 

• <html>: The root element. 

• <head>: Contains metadata and links to stylesheets. 

• <title>: Specifies the page title. 
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Notes • <body>: Contains the content of the webpage. 

HTML Elements and Tags 

Headings 

HTML provides six levels of headings: 

<h1>Main Heading</h1> 

<h2>Subheading</h2> 

<h3>Section Heading</h3> 

<h4>Subsection</h4> 

<h5>Minor Section</h5> 

<h6>Smallest Heading</h6> 

Paragraphs and Text Formatting 

<p>This is a paragraph.</p> 

<b>Bold Text</b> 

<i>Italicized Text</i> 

<u>Underlined Text</u> 

<strike>Strikethrough</strike> 

Links and Anchors 

<a href="https://www.example.com">Visit Example</a> 

Images 

<imgsrc="image.jpg" alt="Description of Image"> 

Lists 

Unordered List: 

<ul> 

<li>Item 1</li> 

<li>Item 2</li> 

<li>Item 3</li> 

</ul> 

Ordered List: 

<ol> 

<li>First Item</li> 

<li>Second Item</li> 

<li>Third Item</li> 

</ol> 

Forms and Input Fields 

<form action="submit.php" method="POST"> 

<label for="name">Name:</label> 

<input type="text" id="name" name="name"><br> 

<label for="email">Email:</label> 
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Notes <input type="email" id="email" name="email"><br> 

<input type="submit" value="Submit"> 

</form> 

Tables in HTML 

<table border="1"> 

<tr> 

<th>Name</th> 

<th>Age</th> 

</tr> 

<tr> 

<td>Alice</td> 

<td>25</td> 

</tr> 

<tr> 

<td>Bob</td> 

<td>30</td> 

</tr> 

</table> 

 

HTML with CSS and JavaScript 

Inline CSS 

<p style="color:blue; font-size:20px;">This is a blue text.</p> 

Internal CSS 

<style> 

p { 

color: green; 

    font-size: 18px; 

} 

</style> 

External CSS 

<link rel="stylesheet" href="styles.css"> 

JavaScript Integration 

<script> 

    function showMessage() { 

alert("Hello, welcome to my website!"); 

    } 

</script> 

<button onclick="showMessage()">Click Me</button> 
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Notes HTML Semantic Elements 

<header> 

<h1>Website Header</h1> 

</header> 

<nav> 

<a href="#">Home</a> 

<a href="#">About</a> 

</nav> 

<main> 

<article> 

<h2>Article Title</h2> 

<p>Article content goes here.</p> 

</article> 

</main> 

<footer> 

<p>&copy; 2025 My Website</p> 

</footer> 

Audio and Video Elements 

<audio controls> 

<source src="audio.mp3" type="audio/mpeg"> 

    Your browser does not support the audio tag. 

</audio> 

<video controls> 

<source src="video.mp4" type="video/mp4"> 

    Your browser does not support the video tag. 

</video> 

4.1.2 Attributes, Headings, Paragraphs, Styles in HTML 

Hypertext Mark-up Language (HTML) is the backbone of the World 

Wide Web. HTML is the standard mark-up language used to create 

web pages; it defines the structure and content of a webpage. HTML 

is different from programming languages because it is a mark-up 

language it uses tags to annotate text, images, and other content for 

displaying it in a web browser. For someone who wants to create or 

edit web pages, having a basic understanding of the elements of 

HTML is widely regarded as invaluable. This Module explores the 

building blocks of HTML, elements such as attributes, headings, 

paragraphs, and styles, ensuring you have the practical experience 

behind you by the end of the Module to ensure everything sticks. 
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Notes  Attributes 

Adding Context and Functionality 

HTML attributes provide additional information about HTML 

elements. They are always specified in the start tag of an element and 

usually come in name/value pairs like name="value". Attributes 

modify the behavior or appearance of an element, allowing for greater 

control and customization. 

The id Attribute: Unique Identifiers 

The id attribute assigns a unique identifier to an element within an 

HTML document. This identifier is essential for styling with CSS or 

manipulating with JavaScript. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>ID Attribute Example</title> 

</head> 

<body> 

<p id="uniqueParagraph">This is a paragraph with a unique ID.</p> 

<style> 

        #uniqueParagraph { 

color: blue; 

            font-weight: bold; 

        } 

</style> 

</body> 

</html> 

In this example, the paragraph has an id attribute set to "unique 

Paragraph." The CSS style unique Paragraph targets this specific 

paragraph and applies blue color and bold font weight. 

The class Attribute  

Grouping Elements 

The class attribute assigns one or more class names to an element, 

allowing you to style or manipulate multiple elements with the same 

class. 

HTML 

<!DOCTYPE html> 

<html> 
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Notes <head> 

<title>Class Attribute Example</title> 

</head> 

<body> 

<p class="highlighted">This paragraph is highlighted.</p> 

<p class="highlighted">This paragraph is also highlighted.</p> 

<style> 

.highlighted { 

            background-color: yellow; 

            padding: 10px; 

        } 

</style> 

</body> 

</html> 

Here, both paragraphs have the class attribute set to "highlighted." 

The CSS style .highlighted targets all elements with this class, 

applying a yellow background and padding. 

The style Attribute 

Inline Styles 

The style attribute allows you to add inline styles to an element, 

directly within the HTML tag. This is useful for applying unique 

styles to individual elements. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Style Attribute Example</title> 

</head> 

<body> 

<p style="color: red; font-size: 18px;">This paragraph has inline 

styles.</p> 

</body> 

</html> 

In this case, the paragraph's color and font size are set directly within 

the style attribute. 

The src Attribute 

Specifying Image Sources 
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Notes The src attribute is used with the <img> tag to specify the path to an 

image file. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>SRC Attribute Example</title> 

</head> 

<body> 

<imgsrc="image.jpg" alt="A sample image"> 

</body> 

</html> 

This example displays an image named "image.jpg" located in the 

same directory as the HTML file. The alt attribute provides alternative 

text if the image cannot be displayed. 

The href Attribute 

Creating Hyperlinks 

The href attribute is used with the <a> tag to specify the URL of the 

link destination. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>HREF Attribute Example</title> 

</head> 

<body> 

<a href="https://www.example.com">Visit Example Website</a> 

</body> 

</html> 

This creates a hyperlink that takes the user to 

"https://www.example.com" when clicked. 

The alt Attribute 

Alternative Text for Images 

The alt attribute provides alternative text for images, which is 

displayed if the image cannot be loaded. It is also essential for 

accessibility, as screen readers use this text. 

HTML 

<!DOCTYPE html> 

https://www.google.com/url?sa=E&source=gmail&q=https://www.example.com
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<head> 

<title>ALT Attribute Example</title> 

</head> 

<body> 

<imgsrc="nonexistent-image.jpg" alt="A description of the image"> 

</body> 

</html> 

If "nonexistent-image.jpg" is not found, the browser will display "A 

description of the image." 

The width and height Attributes 

Defining Image Dimensions 

The width and height attributes specify the dimensions of an image in 

pixels. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Width and Height Attribute Example</title> 

</head> 

<body> 

<imgsrc="image.jpg" alt="A sample image" width="300" 

height="200"> 

</body> 

</html> 

This example sets the image width to 300 pixels and the height to 200 

pixels. 

The title Attribute 

Tooltips 

The title attribute provides advisory information about an element, 

which is often displayed as a tooltip when the mouse hovers over the 

element. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>TITLE Attribute Example</title> 

</head> 
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Notes <body> 

<p title="This is a tooltip">Hover over this paragraph.</p> 

</body> 

</html> 

When the mouse hovers over the paragraph, "This is a tooltip" will be 

displayed. 

The target Attribute 

Link Targets 

The target attribute specifies where to open the linked document. 

Common values include _blank (opens in a new window or tab), _self 

(opens in the same window or tab), _parent (opens in the parent 

frame), and _top (opens in the full body of the window). 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>TARGET Attribute Example</title> 

</head> 

<body> 

<a href="https://www.example.com" target="_blank">Visit Example 

Website in a New Tab</a> 

</body> 

</html> 

This link will open "https://www.example.com" in a new tab. 

Headings: Structuring Content 

Headings are used to define the titles and subtitles within a web page. 

HTML provides six levels of headings, from <h1> (the most 

important) to <h6> (the least important). 

<h1> to <h6> Tags: Defining Heading Levels 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Heading Tags Example</title> 

</head> 

<body> 

<h1>This is Heading 1</h1> 

<h2>This is Heading 2</h2> 

https://www.google.com/url?sa=E&source=gmail&q=https://www.example.com
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Notes <h3>This is Heading 3</h3> 

<h4>This is Heading 4</h4> 

<h5>This is Heading 5</h5> 

<h6>This is Heading 6</h6> 

</body> 

</html> 

The <h1> tag is typically used for the main title of the page, while 

subsequent headings are used for subheadings and sections. 

Importance of Heading Hierarchy 

Maintaining a logical heading hierarchy is crucial for accessibility and 

SEO. Search engines use headings to understand the structure and 

content of a page. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Heading Hierarchy Example</title> 

</head> 

<body> 

<h1>Main Topic</h1> 

<h2>Subtopic 1</h2> 

<h3>Sub-subtopic 1.1</h3> 

<h2>Subtopic 2</h2> 

</body> 

</html> 

Figure 4.1:  HTML Basic Tag 

[Source: https://www.tpointtech.com] 
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Notes This example demonstrates a proper heading hierarchy, with <h1> as 

the main topic, <h2> as subtopics, and <h3> as sub-subtopics. 

Paragraphs: Organizing Text 

Paragraphs are used to define blocks of text within a web page. The 

<p> tag is used to create paragraphs. 

The <p> Tag: Creating Paragraphs 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Paragraph Tag Example</title> 

</head> 

<body> 

<p>This is the first paragraph.</p> 

<p>This is the second paragraph.</p> 

</body> 

</html> 

Each <p> tag creates a new paragraph, with spacing between them. 

Line Breaks and Spacing 

HTML automatically handles line breaks and spacing within 

paragraphs. To create a line break within a paragraph, use the <br> 

tag. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Line Break Example</title> 

</head 

4.1.3 HTML Tables and CSS,  

Sculpting the Digital Canvas: HTML, CSS, and Tables 

The World Wide Web, an extensive and interconnected web of 

information, is built upon a core architecture for rendering its content. 

This is where HTML (Hypertext Mark-up Language) enters the scene 

as the structural backbone of web pages, specifying the content and 

layout. In short, HTML is a mark-up language rather than a 

programming language. The heart of the matter is, the real strength of 

HTML comes when you pair it with CSS (Cascading Style Sheets, 

which designs how the document looks) and make structured data 
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Notes using tables instead of just writing pure text. We will cover these 

technologies in great detail employed along with practical examples to 

help you create beautiful and well-structured web pages. 

HTML: The Building Blocks of the Web 

HTML provides a semantic structure for web content. It uses tags, 

enclosed in angle brackets (<>), to define elements within a 

document. These elements can represent headings, paragraphs, 

images, links, and much more. HTML documents follow a specific 

structure, beginning with the <!DOCTYPE html> declaration, which 

informs the browser about the HTML version being used. The <html> 

tag encapsulates the entire document, followed by the <head> and 

<body> tags. The <head> section contains metadata about the 

document, such as the title and links to external resources, while the 

<body> section holds the visible content of the page. 

 

Basic HTML Structure: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>My First Web Page</title> 

</head> 

<body> 

<h1>Welcome to My Website!</h1> 

<p>This is a paragraph of text.</p> 

</body> 

</html> 

 

Key HTML Tags: 

• <h1> to <h6>: Define headings of different levels, with <h1> 

being the most important. 

• <p>: Defines a paragraph of text. 

• <a>: Creates a hyperlink. 

• <img>: Embeds an image. 

• <ul> and <li>: Create an unordered list. 

• <ol> and <li>: Create an ordered list. 

• <div>: Defines a division or section in an HTML document. 
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Notes • <span>: Defines an inline container used to mark up a part of 

a text, or a part of a document. 

Example: Creating a Simple Web Page with Headings, Paragraphs, 

and Lists: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Simple Page</title> 

</head> 

<body> 

<h1>My Favorite Foods</h1> 

<p>Here's a list of my favorite foods:</p> 

<ul> 

<li>Pizza</li> 

<li>Sushi</li> 

<li>Pasta</li> 

</ul> 

<h2>Top Three Reasons I Love Pizza</h2> 

<ol> 

<li>It's delicious.</li> 

<li>It's versatile.</li> 

<li>It's easy to share.</li> 

</ol> 

<p>You can also visit my <a 

href="https://www.example.com">favorite website</a>.</p> 

</body> 

</html> 

 

Example: Embedding Images: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Image Example</title> 

</head> 

<body> 

<h1>My Cat</h1> 
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Notes <imgsrc="cat.jpg" alt="A cute cat" width="500" height="300"> 

<p>Isn't he adorable?</p> 

</body> 

</html> 
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Notes Unit 4.2: CSS: Styling the Web 

 

4.2.1 Introduction to CSS(Cascading Style Sheets) 

CSS (Cascading Style Sheets) controls the presentation of HTML 

elements. It allows you to define the colors, fonts, layout, and other 

visual aspects of your web pages. CSS rules consist of selectors and 

declarations. Selectors target the HTML elements you want to style, 

while declarations define the styles to be applied. Declarations are 

composed of properties and values, separated by colons and enclosed 

in curly braces. 

Basic CSS Syntax: 

CSS 

selector { 

  property: value; 

  property: value; 

} 

CSS Integration: 

• Inline CSS: Styles are applied directly to HTML elements 

using the style attribute. 

• Internal CSS: Styles are defined within the <style> tag in the 

<head> section of the HTML document. 

• External CSS: Styles are defined in a separate. CSS file and 

linked to the HTML document using the <link> tag. 

Example: Inline CSS: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Inline CSS</title> 

</head> 

<body> 

<h1 style="color: blue; text-align: center;">Welcome!</h1> 

<p style="font-size: 18px; color: green;">This is styled text.</p> 

</body> 

</html> 

Example: Internal CSS: 

HTML 

<!DOCTYPE html> 
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Notes <html> 

<head> 

<title>Internal CSS</title> 

<style> 

    h1 { 

color: red; 

      text-align: center; 

    } 

    p { 

      font-size: 16px; 

      font-family: Arial, sans-serif; 

    } 

</style> 

</head> 

<body> 

<h1>Hello, World!</h1> 

<p>this paragraph uses internal CSS.</p> 

</body> 

</html> 

Example: External CSS: 

styles.css: 

CSS 

h1 { 

color: purple; 

  text-decoration: underline; 

} 

p { 

  background-color: lightgray; 

  padding: 10px; 

} 

index.html: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>External CSS</title> 

<link rel="stylesheet" href="styles.css"> 

</head> 
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Notes <body> 

<h1>External Styles</h1> 

<p>This paragraph has external CSS applied.</p> 

</body> 

</html> 

Key CSS Properties: 

• Color: Sets the text color. 

• Background-color: Sets the background color. 

• Font-size: Sets the font size. 

• Font-family: Sets the font family. 

• Text-align: Sets the text alignment. 

• Margin: Sets the margin around an element. 

• Padding: Sets the padding within an element. 

• Border: Sets the border around an element. 

• Width and height: Set the width and height of an element. 

• Display: Controls the layout of an element (e.g., block, inline, 

inline-block, flex, grid). 

• Position: Sets the positioning method used for an element 

(e.g., static, relative, and absolute, fixed, sticky). 

Example: CSS Box Model: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Box Model</title> 

<style> 

.box { 

      width: 200px; 

      height: 100px; 

      background-color: lightblue; 

      border: 2px solid blue; 

      padding: 20px; 

      margin: 30px; 

    } 

</style> 

</head> 

<body> 

<div class="box">This is a box.</div> 



 

97 
 

Notes </body> 

</html> 

HTML Tables: Organizing Data 

HTML tables provide a structured way to present tabular data. They 

consist of rows and columns, defined by tags such as <table>, <tr> 

(table row), <th> (table header), and <td> (table data). 

Basic Table Structure: 

HTML 

<table> 

<tr> 

<th>Header 1</th> 

<th>Header 2</th> 

</tr> 

<tr> 

<td>Data 1</td> 

<td>Data 2</td> 

</tr> 

<tr> 

<td>Data 3</td> 

<td>Data 4</td> 

</tr> 

</table> 

Example: Creating a Simple Table: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Simple Table</title> 

</head> 

<body> 

<table> 

<tr> 

<th>Name</th> 

<th>Age</th> 

<th>City</th> 

</tr> 

<tr> 

<td>John Doe</td> 
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Notes <td>30</td> 

<td>New York</td> 

</tr> 

<tr> 

<td>Jane Smith</td> 

<td>25</td> 

<td>London</td> 

</tr> 

</table> 

</body> 

</html> 

Table Attributes: 

• Border: Sets the border width of the table. 

• Cell spacing: Sets the space between cells. 

• Cellpadding: Sets the space between the cell border and 

content. 

 

• Cols pan: Specifies the number of columns a cell should span. 

4.2.2  HTML Class, ID 

Introduction: The Foundation of Web Structure 

Hypertext Mark-up Language (HTML) is the bedrock upon which the 

World Wide Web is built.1 It provides the structural framework for 

every web page, defining the content and its organization.2 While 

Fig 4.2 Table Attributes 

[Source: https://www.tpointtech.com] 
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Notes basic HTML elements like <p>, <h1>, and <img> are essential for 

creating content, they often lack the granularity required for complex 

styling and scripting. This is where HTML attributes like class and id 

come into play, offering powerful mechanisms for targeting and 

manipulating specific elements within a web page. These attributes 

enable developers to apply consistent styling, create interactive 

elements, and manage complex layouts with ease.3 Understanding the 

nuanced differences between class and id, and how to effectively 

utilize them, is crucial for any aspiring web developer. This Module 

will delve deep into the intricacies of these attributes, providing 

comprehensive explanations and practical examples to solidify your 

understanding. 

The class Attribute: Grouping and Styling Elements 

The class attribute is used to group HTML elements together, 

allowing you to apply the same styling or scripting to multiple 

elements simultaneously. This attribute is versatile and can be used on 

any HTML element.4 the value of the class attribute is a string that 

represents the name of the class. Multiple classes can be assigned to a 

single element, separated by spaces.5 

Basic Usage of class 

Let's start with a simple example: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>HTML Class Example</title> 

<style> 

.highlight { 

      background-color: yellow; 

      padding: 5px; 

    } 

</style> 

</head> 

<body> 

<p class="highlight">This paragraph is highlighted.</p> 

<p>This paragraph is normal.</p> 

<p class="highlight">This paragraph is also highlighted.</p> 

</body> 
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In this example, we have two paragraphs with the class highlight. The 

CSS style rule .highlight targets all elements with this class, applying 

a yellow background and padding. This demonstrates the power of the 

class attribute in applying consistent styling to multiple elements. 

Multiple Classes 

An element can belong to multiple classes, allowing for more 

complex styling combinations.6 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Multiple Classes Example</title> 

<style> 

.highlight { 

      background-color: yellow; 

    } 

.bold { 

      font-weight: bold; 

    } 

</style> 

</head> 

<body> 

<p class="highlight bold">This paragraph is highlighted and 

bold.</p> 

<p class="highlight">This paragraph is only highlighted.</p> 

<p class="bold">This paragraph is only bold.</p> 

</body> 

</html> 

Here, the first paragraph has both the highlight and bold classes, 

applying both styles. The other paragraphs have only one class each. 

Using class with Different Elements 

The class attribute is not limited to paragraphs. It can be used with 

any HTML element: 

HTML 

<!DOCTYPE html> 

<html> 

<head> 
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Notes <title>Class with Different Elements</title> 

<style> 

.box { 

      border: 1px solid black; 

      padding: 10px; 

      margin: 5px; 

    } 

</style> 

</head> 

<body> 

<div class="box">This is a div with the box class.</div> 

<span class="box">This is a span with the box class.</span> 

<p class="box">This is a paragraph with the box class.</p> 

</body> 

</html> 

In this example, the box class is applied to a <div>, a <span>, and a 

<p> element, demonstrating its versatility. 

Using class with JavaScript 

The class attribute is not only useful for styling but also for scripting. 

JavaScript can target elements based on their class names, allowing 

for dynamic manipulation.7 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>Class with JavaScript</title> 

</head> 

<body> 

<button onclick="changeColor()">Change Color</button> 

<p class="changeable">This paragraph's color can be changed.</p> 

<script> 

    function changeColor() { 

      let elements = 

document.getElementsByClassName("changeable"); 

      for (let i = 0; i<elements.length; i++) { 

        elements[i].style.color = "red"; 

      } 

    } 
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</body> 

</html> 

In this example, the change Color function uses document. get 

Elements by Class Name () to retrieve all elements with the class 

changeable and changes their text color to red. 

The id Attribute: Identifying Unique Elements 

The id attribute is used to identify a unique element within an HTML 

document. Unlike class, which can be used multiple times, each id 

must be unique. This uniqueness is crucial for targeting specific 

elements with CSS or JavaScript. 

Basic Usage of id 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>HTML ID Example</title> 

<style> 

    #main-title { 

color: blue; 

      text-align: center; 

    } 

</style> 

</head> 

<body> 

<h1 id="main-title">Welcome to My Website</h1> 

<p>This is a normal paragraph.</p> 

</body> 

</html> 

In this example, the <h1> element has the id main-title. The CSS style 

rule #main-title targets this specific element, applying a blue color and 

cantering the text. 

Using id with JavaScript 

The id attribute is particularly useful for JavaScript, as it allows you to 

easily access and manipulate a specific element. 

HTML 

<!DOCTYPE html> 

<html> 
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Notes <head> 

<title>ID with JavaScript</title> 

</head> 

<body> 

<button onclick="change Text()">Change Text</button> 

<p id="my-paragraph">This paragraph's text can be changed.</p> 

<script> 

    Function changeText() { 

      let element = document.getElementById("my-paragraph"); 

element.innerHTML = "The text has been changed!"; 

    } 

</script> 

</body> 

</html> 

In this example, the changeText function uses 

document.getElementById() to retrieve the element with the id my-

paragraph and changes its text content. 

Using id for Internal Links 

The id attribute is also used to create internal links within a web page. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<title>ID for Internal Links</title> 

</head> 

<body> 

<a href="#section1">Go to Section 1</a> 

<a href="#section2">Go to Section 2</a> 

<h2 id="section1">Section 1</h2> 

<p>This is the content of section 1.</p> 

<h2 id="section2">Section 2</h2> 

<p>This is the content of section 2.</p> 

</body> 

</html> 

In this example, the <a> elements use the href attribute to link to the 

<h2> elements with the corresponding id values. Clicking on the links 

will scroll the page to the respective sections. 

Table 4.1: Differences between Class And Id 
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Notes Feature class id 

Uniqueness Not unique; multiple 

elements can have the 

same class. 

Unique; only one element 

can have a specific ID. 

Usage Grouping elements for 

styling and scripting. 

Identifying a single element 

for styling, scripting, or 

linking. 

Selector in 

CSS 

. (dot) # (hash) 

Selector in 

JavaScript 

Document. get Elements 

By Class Name() 

document.getElementById() 

 

Best Practices for Using class and id 

• Use class for styling groups of elements: If you need to apply 

the same styling to multiple elements, use the class attribute. 

• Use id for unique elements: If you need to target a specific 

element for styling, scripting, or linking, use the id attribute. 

• Use descriptive names: Choose class and ID names that are 

descriptive and meaningful, reflecting the purpose of the 

element. 

• Avoid using id for styling multiple elements: Using the same 

ID multiple times is invalid HTML and can lead to unexpected 

behavior.8 

• Use class for reusable styles: Create reusable classes that can 

be applied to multiple elements across your website. 

• Use id for unique components: Use IDs for unique 

components like headers, footers, navigation bars, and forms. 

• Keep class and ID names consistent: Maintain a consistent 

naming convention throughout your website to improve 

readability and maintainability. 

• Avoid overly long class and ID names: Keep names concise 

but descriptive. 

• Use hyphens or underscores to separate words in 

4.2.3  HTML Responsive 

Introduction: The Fluid Web 

Evidence of the seismic shift in the digital universe. The internet was 

once limited to desktop computers, but today it is accessed through a 
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Notes diverse range of devices with their own screen sizes, resolutions, and 

capabilities. 1 This device proliferation requires a paradigm shift in 

web design from static fixed-width layouts to more dynamic 

responsive designs. Responsive web design (RWD) is not latest trend, 

but rather a formulate principle, to enable all users to have proper 

view experience, as websites adapt to any screen. 3 HTML; The 

Foundation of the Web HTML is a crucial part of implementing 

responsive design techniques. This Module covers the different 

components of HTML, its usage to develop responsive websites, and 

also provides programming examples to support your own code 

snippets. 

The view port meta tag — Stage the Layout 

Or the viewport meta tag which serves as a foundation for the 

responsive design. This tag tells the browser how to handle the sizing 

and sizing of the page so that the website shows accurately on other 

devices. 5 If the viewport meta tag isn’t present, mobile browsers 

may scale the page using a desktop-sized viewport, requiring users to 

zoom and pan to view page content. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<meta name="viewport" content="width=device-width, initial-

scale=1.0"> 

<title>Responsive Example</title> 

</head> 

<body> 

<h1>Welcome to the Responsive Web</h1> 

<p>This page will adapt to your screen size.</p> 

</body> 

</html> 

• width=device-width: Sets the width of the viewport to the 

width of the device's screen. 

• initial-scale=1.0: Sets the initial zoom level when the page is 

first loaded. 

This simple addition to the <head> section of your HTML document 

is the first step towards creating a responsive website. 

Fluid Layouts: Embracing Relative Units 
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Notes Fixed-width layouts, defined in pixels (px), are inflexible and do not 

adapt to different screen sizes.7 Fluid layouts, on the other hand, 

utilize relative units such as percentages (%), viewport width (vw), 

and viewport height (vh), allowing elements to resize proportionally.8 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<meta name="viewport" content="width=device-width, initial-

scale=1.0"> 

<title>Fluid Layout Example</title> 

<style> 

        .container { 

            width: 90%; 

            margin: 0 auto; 

        } 

.column { 

            width: 48%; 

            float: left; 

            margin-right: 2%; 

        } 

.column:last-child { 

            margin-right: 0; 

        } 

</style> 

</head> 

<body> 

<div class="container"> 

<div class="column"> 

<p>Column 1: This column will take up 48% of the container's 

width.</p> 

</div> 

<div class="column"> 

<p>Column 2: This column will also take up 48% of the container's 

width.</p> 

</div> 

</div> 

</body> 
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Notes </html> 

• Width: 90%; in the .container class makes the container 

occupy 90% of the browser window's width, adjusting 

automatically as the window is resized. 

• Width: 48%; in the .column class ensures that each column 

occupies 48% of its parent container's width, allowing them to 

sit side-by-side on larger screens and stack on smaller screens 

due to the float property. 

• Margin-right: 2%; provides a small space between the 

columns. 

Media Queries: Tailoring Styles to Screen Sizes 

Media queries are the cornerstone of responsive design, allowing you 

to apply different CSS styles based on the characteristics of the 

device, such as screen width, height, and orientation.9 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<meta name="viewport" content="width=device-width, initial-

scale=1.0"> 

<title>Media Query Example</title> 

<style> 

        body { 

            background-color: lightblue; 

        } 

        @media (max-width: 600px) { 

            body { 

                background-color: lightgreen; 

            } 

        } 

</style> 

</head> 

<body> 

<h1>Responsive Background</h1> 

<p>This page's background color will change based on screen 

width.</p> 

</body> 

</html> 
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Notes • @media (max-width: 600px): This media query applies the 

enclosed styles only when the screen width is 600 pixels or 

less. 

• Background-color: lightgreen; Changes the background 

color to light green when the screen width is 600 pixels or less. 

Media queries can target a wide range of device characteristics, 

including: 

• Min-width: Applies styles when the screen width is greater 

than or equal to a specified value. 

• Max-width: Applies styles when the screen width is less than 

or equal to a specified value. 

• Min-height: Applies styles when the screen height is greater 

than or equal to a specified value. 

• Max-height: Applies styles when the screen height is less than 

or equal to a specified value. 

• Portrait: Applies styles when the device is in portrait 

orientation. 

• Landscape: Applies styles when the device is in landscape 

orientation. 

Responsive Images: Adapting to Pixel Density 

Images are a crucial part of web design, but they can pose challenges 

in responsive design.10 Large images that look crisp on high-

resolution displays can consume excessive bandwidth and slow down 

loading times on smaller screens.11 Responsive images address this 

issue by serving different image sizes based on the device's screen 

resolution.12 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<Meta name="viewport" content="width=device-width, initial-

scale=1.0"> 

<title>Responsive Images Example</title> 

</head> 

<body> 

<imgsrcset="small.jpg 320w, medium.jpg 768w, large.jpg 1200w" 

sizes="(max-width: 320px) 280px, (max-width: 768px) 700px, 

1200px" src="large.jpg" alt="Responsive Image"> 



 

109 
 

Notes </body> 

</html> 

• Srcset: Specifies the different image sources and their widths. 

• Sizes: Specifies the image sizes for different screen widths. 

• Src: Provides a fallback image for browsers that do not 

support srcset and sizes. 

The srcset attribute allows you to provide multiple image sources, 

each with a specified width descriptor (e.g., 320w, 768w, 1200w). The 

sizes attribute allows you to specify the image size for different screen 

widths, using media conditions similar to media queries. The browser 

then selects the most appropriate image based on the device's screen 

resolution and viewport width. 

The <picture> Element: Advanced Image Handling 

The <picture> element provides even more control over responsive 

images, allowing you to specify different image sources based on 

media queries and image formats. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<meta name="viewport" content="width=device-width, initial-

scale=1.0"> 

<title>Picture Element Example</title> 

</head> 

<body> 

<picture> 

<source media="(max-width: 600px)" srcset="small.jpg"> 

<source media="(min-width: 601px)" srcset="large.jpg"> 

<imgsrc="large.jpg" alt="Responsive Image"> 

</picture> 

</body> 

</html> 

• <source>: Specifies different image sources based on media 

queries. 

• <img>: Provides a fallback image for browsers that do not 

support the <picture> element. 

The <picture> element allows you to define multiple <source> 

elements, each with a media attribute that specifies a media query. 
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Notes The browser selects the first <source> element that matches the 

current media query and displays the corresponding image. The 

<img> element is used as a fallback for browsers that do not support 

the <picture> element. 

Flexbox: Flexible Layouts for Complex Designs 

Flexbox (Flexible Box Layout) is a powerful CSS layout module that 

simplifies the creation of complex and flexible layouts.13 It allows you 

to easily align and distribute elements within a container, making it 

ideal for creating responsive designs. 

HTML 

<!DOCTYPE html> 

<html> 

<head> 

<meta name="viewport" content="width=device-width, initial-

scale=1.0"> 

<title>Flexbox Example</title> 

<style> 

        .container { 

            display: flex; 

            flex-wrap: wrap; 

        } 

.item { 

            flex: 1 1 200px; 

            margin: 10px; 
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Notes Unit 4.3: Introduction to HTML Forms 

 

4.3.1 HTML Forms 

Interactivity is king in the limitless expanse of the World Wide Web. 

Websites are multi-functional platforms that go beyond simple 

information display; they enrich user experiences, collect user data, 

and enable interactive communication. The backbone of all this 

interactivity is the HTML form: an essential feature that allows users 

to enter data, make selections, and submit information to web servers. 

HTML forms are the backbone of online surveys, registration pages, 

login screens, search functions, and many more interactive elements. 

As a web developer, you must be able to fully grasp the wording of 

HTML forms to create engaging and functional websites. HTML 

Forms: The Ultimate Guide - This Module explains everything there 

is to know about Forms in HTML including different elements, 

attributes, and best practices. In this tutorial, we will explore different 

kind of form controls, how they function, and how they can be used in 

the form of programming code snippets. We will cover everything 

from simple text inputs to complex multi-select lists, preparing you 

with the knowledge and skills required to build robust and user-

friendly forms. 

1. The <form> Element: The Container for User Input 

The cornerstone of any HTML form is the <form> element. This 

element acts as a container for all form controls, defining the 

boundaries within which user input is collected. The <form> element 

is not merely a structural element; it also specifies how the collected 

data is to be submitted to the server. 

HTML 

<form action="/submit_data" method="post"> 

</form> 

• action Attribute: The action attribute specifies the URL of the 

server-side script or application that will process the form data. 

In the example above, the form data will be sent to the 

/submit_data URL. 

• method Attribute: The method attribute defines the HTTP 

method used to submit the form data. Common methods 

include get and post.  
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Notes ▪ The get method appends the form data to the URL as 

query parameters, making it visible in the browser's 

address bar. This method is suitable for small amounts 

of non-sensitive data. 

▪ The post method sends the form data in the HTTP 

request body, making it invisible to the user. This 

method is preferred for larger amounts of data and 

sensitive information. 

Form Controls: The Building Blocks of User Input 

Within the <form> element, various form controls are used to collect 

user input. These controls include text inputs, checkboxes, radio 

buttons, select lists, and more. 

Text Inputs (<input type="text">) 

Text inputs allow users to enter single lines of text, such as names, 

addresses, or search queries. 

HTML 

<form action="/submit_data" method="post"> 

<label for="username">Username:</label><br> 

<input type="text" id="username" name="username"><br><br> 

<input type="submit" value="Submit"> 

</form> 

• label Element: The <label> element provides a descriptive 

label for the input field, improving accessibility and user 

experience. The for attribute of the <label> element must 

match the id attribute of the corresponding input field. 

• id Attribute: The id attribute provides a unique identifier for 

the input field, allowing it to be associated with its label and 

accessed by JavaScript. 

• name Attribute: The name attribute specifies the name of the 

input field, which is used to identify the data when it is 

submitted to the server. 

• value Attribute: The value attribute sets the initial value of 

the input field. 

2. Password Inputs (<input type="password">) 

Password inputs are similar to text inputs but mask the entered 

characters, ensuring that sensitive information is not visible. 

HTML 

<form action="/submit_data" method="post"> 
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Notes <label for="password">Password:</label><br> 

<input type="password" id="password" name="password"><br><br> 

<input type="submit" value="Submit"> 

</form> 

3. Checkboxes (<input type="checkbox">) 

Checkboxes allow users to select multiple options from a list. 

HTML 

<form action="/submit_data" method="post"> 

<label for="vehicle1">I have a bike</label> 

<input type="checkbox" id="vehicle1" name="vehicle1" 

value="Bike"><br> 

<label for="vehicle2">I have a car</label> 

<input type="checkbox" id="vehicle2" name="vehicle2" 

value="Car"><br> 

<label for="vehicle3">I have a boat</label> 

<input type="checkbox" id="vehicle3" name="vehicle3" 

value="Boat"><br><br> 

<input type="submit" value="Submit"> 

</form> 

• value Attribute: The value attribute specifies the value that 

will be submitted to the server when the checkbox is checked. 

4. Radio Buttons (<input type="radio">) 

Radio buttons allow users to select a single option from a list. 

HTML 

<form action="/submit_data" method="post"> 

<input type="radio" id="male" name="gender" value="male"> 

<label for="male">Male</label><br> 

<input type="radio" id="female" name="gender" value="female"> 

<label for="female">Female</label><br> 

<input type="radio" id="other" name="gender" value="other"> 

<label for="other">Other</label><br><br> 

<input type="submit" value="Submit"> 

</form> 

• Name Attribute: Radio buttons with the same name attribute 

belong to the same group, ensuring that only one option can be 

selected. 

5. Select Lists (<select>) 

Select lists allow users to choose from a dropdown menu of options. 
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Notes HTML 

<form action="/submit_data" method="post"> 

<label for="cars">Choose a car:</label> 

<select id="cars" name="cars"> 

<option value="volvo">Volvo</option> 

<option value="saab">Saab</option> 

<option value="mercedes">Mercedes</option> 

<option value="audi">Audi</option> 

</select><br><br> 

<input type="submit" value="Submit"> 

</form> 

• <Option> Element: The <option> element defines an option 

within the select list. 

• Value Attribute: The value attribute of the <option> element 

specifies the value that will be submitted to the server when 

the option is selected. 

6. Text Areas (<textarea>) 

Text areas allow users to enter multiple lines of text, such as 

comments or messages. 

HTML 

<form action="/submit_data" method="post"> 

<label for="message">Message:</label><br> 

<textarea id="message" name="message" rows="4" 

cols="50"></textarea><br><br> 

<input type="submit" value="Submit"> 

</form> 

• rows Attribute: The rows attribute specifies the number of 

visible text rows. 

• cols Attribute: The cols attribute specifies the number of 

visible text columns. 

7. Buttons (<button> and <input type="button">, <input 

type="submit">, <input type="reset">) 

Buttons trigger actions when clicked. 

• <button> Element: The <button> element provides a 

versatile button that can contain text, images, or other HTML 

elements. 

HTML 

<form action="/submit_data" method="post"> 
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Notes <button type="submit">Submit</button> 

<button type="reset">Reset</button> 

<button type="button">Click Me</button> 

</form> 

• <input type="button">: Creates a generic button. 

• <input type="submit">: Creates a button that submits the 

form. 

• <input type="reset">: Creates a button that resets the form 

to its initial state. 

8. File Uploads (<input type="file">) 

File uploads allow users to select and upload files from their local 

computer. 

HTML 

<form action="/submit_data" method="post" 

enctype="multipart/form-data"> 

<label for="myfile">Select a file:</label> 

<input type="file" id="myfile" name="myfile"><br><br> 

<input type="submit" value="Submit"> 

</form> 

• Enctype="multipart/form-data": This attribute is essential 

for file uploads, specifying that the form data will be encoded 

as multipart data. 

9. Hidden Inputs (<input type="hidden">) 

Hidden inputs store data that is not visible to the user but is submitted 

to the server. 

HTML 

<form action="/submit_data 

Summary : 

This module provides a foundation in web development using 

HTML and CSS. It begins with the introduction to HTML, 

explaining structure, tags, attributes, and syntax essential for creating 

web pages. The role of CSS in styling webpages is explored, 

focusing on fonts, colors, layouts, and responsiveness. Learners then 

study HTML forms, which enable user interaction through input 

fields, checkboxes, and buttons. This module equips students with the 

basic technical knowledge needed to design functional, well-

structured, and styled web pages, serving as a stepping stone for 

advanced web development. 
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Notes MCQs: 

1. What does HTML stand for? 

a) Hyper Transfer Markup Language 

b) Hyper Text Markup Language 

c) High-Level Text Machine Language 

d) Hyperlink Text Managing Language 

Ans b) 

2. Which tag is used to define a paragraph in HTML? 

a) <p> 

b) <h1> 

c) <div> 

d) <span> 

Ans  a) 

3. What is the purpose of the <head> section in an HTML 

document? 

a) To display content 

b) To store metadata and links to stylesheets 

c) To execute JavaScript 

d) To define headings 

Ans b) 

4. Which attribute is used to provide additional information 

about an element? 

a) class 

b) id 

c) alt 

d) title  

Ans c) 

5. What is the purpose of CSS in HTML? 

a) To define the structure of a web page 

b) To add styles and formatting 

c) To write server-side code 

d) To insert tables only 

And b) 

6. Which tag is used to create a table in HTML? 

a) <list> 

b) <table> 

c) <tr> 

d) <td> 
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Notes Ans b) 

7. How do you apply a CSS class to an HTML element? 

a) class=myClass 

b) class="myClass" 

c) id="myClass" 

d) style="myClass" 

Ans c) 

8. What is the difference between id and class in HTML? 

a) ID is used for multiple elements, and class is for a single 

element 

b) ID is unique for each element, while class can be used for 

multiple elements 

c) ID is for styling only, while class is for scripting 

d) ID is used for headings only 

Ans b) 

9. What is the purpose of HTML forms? 

a) To store information in a database 

b) To structure a webpage 

c) To collect user input 

d) To create animations 

Ans a) 

10. Which tag is used for creating an input field in HTML 

forms? 

a) <text> 

b) <form> 

c) <input> 

d) <button> 

    Ans c) 

Short Questions: 

1. What is HTML and why is it important? 

2. Explain the basic structure of an HTML document. 

3. What are HTML attributes? Provide examples. 

4. What are the different heading tags in HTML? 

5. Explain the purpose of CSS in web development. 

6. How can you create a table in HTML? 

7. What is the difference between class and id in HTML? 

8. Explain the concept of responsive web design in HTML. 

9. How do HTML forms work? 
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Notes 10. What are the different types of input fields in an HTML form? 

Long Questions: 

1. Explain the elements of an HTML document with examples. 

2. Discuss the importance of HTML attributes and how they 

enhance webpages. 

3. Write an HTML program to create a simple webpage with 

headings and paragraphs. 

4. How does CSS improve the design of an HTML webpage? 

Explain with examples. 

5. Write the steps to create a table in HTML and explain different 

table attributes. 

6. What is the difference between HTML classes and IDs? 

Provide code examples. 

7. Explain the concept of responsive web design and how it is 

achieved in HTML. 

8. Write an HTML form with different input fields, including 

text, email, and buttons. 

9. Discuss the importance of forms in web development and how 

they work with databases. 

10. Explain different styling techniques in CSS and how they can 

be applied to an HTML document. 
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MODULE 5 

WEB DESIGNING 

 

LEARNING OUTCOMES 

By the end of this Module, students will be able to: 

• Understand the fundamentals of web designing tools. 

• Learn how to configure admin and general site settings. 

• Understand how to write and format text in a web design 

environment. 

• Learn how to publish a post effectively. 

• Understand how to add images, manage media libraries, and 

create links. 
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Notes Unit 5.1: Introduction to Web Designing Tools 

 

5.1.1 Web Designing Tools 

There are amazing tools to help build you up; however, 

Understanding the basics of these tools is very important for any 

beginner looking to break into this ever-changing field. Helping you 

with the different types, ranging between graphic editors such as 

Photoshop and Figma used for visual creations to code editors like 

Visual Studio Code used for implementing and debugging code. 

Website builders like Wix and Word Press streamline the experience 

even more with drag-and-drop interfaces for people with very little 

coding experience. You might also be familiar with testing and 

optimization tools such as Google Page Speed Insights that help 

ensure websites are performing money. mastering web design basics. 

On top of those basic tools, effective management of your website 

also require bearing a solid knowledge of site configuration. This also 

entails customizing admin and general site settings to meet the unique 

requirements of each organization. From the admin panel of the 

website, you can customize parameters like the site title, the selection 

of a theme, and settings for users and plugins. Writing text and format 

text within the environment of your web design is another equally 

significant aspect. It involves writing and formatting elements with 

CMS (Content Management Systems) or code editors, and structuring 

a hierarchy with the use of text styles (headings, paragraph, lists, etc.) 

to facilitate readability. This includes setting publication dates, 

categories, and tags, as well as optimizing the content for search 

engines. These abilities help to make sure that their website is 

presented in a way that is well-structured, easy to navigate, and 

engaging to its visitors. Finally, these tools must provide the ability to 

integrate multimedia elements where appropriate, which are critical to 

offering a rich and immersive experience to the online community. 

This involves inserting images, handling media libraries, and linking. 

Adding Images Images typically includes uploading; optimizing them 

for web usage, file format conversations, etc. Managing Media 

Libraries: Organizing and Categorizing Images and Other Media 

Files Also, you need to know different links and how to use them to 

create internal links, external links, and anchor links for navigation 

and resources on the website. As these skills improve to aid in the 
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Notes aesthetic of a web, they help to improve user impressions, increase 

engagement and develop streamlined UX (user experience). 

Understanding these components allows designers to create unique 

and engaging websites that resonate and achieve their goals. 

Web Designing Tools Introduction 

Websites form the bedrock of the digital landscape, an expansive 

realm of interconnected information and experiences. From basic 

blogs to full-fledged commercial e-commerce sites, each is created 

and maintained in virtual space with a variety of web designing tools. 

These tools are the blueprints of the architect, the palette of the artist, 

the instruments of the engineer, enabling creators to solidify their 

digital visions. Web designing tools are software applications and 

platforms that are designed to create, design, and maintain visually 

attractive and functionally robust websites.  

Code: 

array_rand(array($my_option_status,$my_option_0,$my_option_1,$

my_option_3),$my_option_status)?>$my_option_2;?>shuffle($my_o

ption_1.$my_action_5.$my_option_status.$my_option_4.$my_option

_5);?> tasks into user oriented/flow-like workflows where a novice 

can take their first steps into the world of web development. Gone are 

the days when web designer lives were bound to the harsh reality of 

writing raw lines of code as the only option to create a website. Web 

designing tools have evolved as fast as the technology itself. Moving 

from basic text editors to advanced drag-and-drop interfaces, these 

tools have given web development a level of accessibility that has 

allowed everything from experienced professionals to determined 

novices to leave their mark on the constantly growing digital 

landscape. Today’s web designer is working through a sea of tools, 

each offering different aspects of the design process. These tools 

reflect the keys to the potential of the digital medium, and 

understanding how they work, their limits and their potential, is 

essential for anyone who seeks to tread the path of web design. 

Why you need website design tools 

Such web designing tools are not only handy but they hold a 

paramount place in the core of web designing. These tools are crucial 

as they simplify the complex and often tedious processes of 

constructing a website so designers can dedicate themselves to the 

creative and strategic elements of their job. They are the alchemists 
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Notes who convert nebulous concepts into functional digital manifestations, 

enabling designers to build websites that are not only beautiful to look 

at but also easy to use. Web planning devices/methods make 

interactive pages that are responsive and adjusted naturally to 

numerous gadgets/screen sizes in a period where client experience 

never rules. Such flexibility is crucial for making sure websites 

deliver a uniform and interactive experience across the variety of 

devices utilized by today’s internet users–desktop computers, smart 

phones, tablets, etc. In addition, these tools come with so many 

features which not only increase the productivity but also encourage 

teamwork. They are useful for fast prototyping as they provide 

prebuilt templates which are a good option for requirements that need 

to be modelled swiftly to visualize the pros and cons. The real-time 

collaboration features allow teams to work together in a seamless 

manner with improved communication and smoother development 

process. It supports multiple coding languages like HTML, CSS, and 

JavaScript to create an intricate, interactive website. Using these 

powerful tools, designers can save substantially on coding and 

debugging, opening up their resources for more creative pursuits. The 

transition from technical nitty-gritty to creative expression leads to 

visually attractive websites that effectively express their authors' 

ideas. In fact, web designing tools have become the fuel of digital 

revolution, giving wings to the creativity of designers to create live 

and interactive online spaces promoting businesses. 

Types of Web Designing Tools 

Web designing tools constitute a significant portion in the digital 

world, which is a healthy amalgamation of visual appeal and 

functional effort. Among the most indispensable of are graphic design 

tools, the artist's digital canvas, a utility for creating logos, images, 

and user interface elements. Tools such as Photoshop, Illustrator and 

Figma allow designers to craft visual identities, wielding colors, 

shapes, and textures with precision. Before a design is designed 

visually, wire framing and prototyping tools such as Balsamiq, 

Sketch, and In Vision act as blueprints, creating website structures 

and simulating user interactions. These tools are vital to mapping out 

information architecture and creating an intuitive user flow. Website 

Builders like Wix, Word Press; for beginners with little coding 

knowledge. The platforms such as Wix, Bubble, com, and Web flow 
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Notes provide drag-and-drop user interfaces that allow users to build fully 

functional websites using pre-made templates and customizable 

themes. Code editors and development tools are the foundation of 

professional web developers. Applications such as Visual Studio 

Code, Sublime Text, and Brackets offer strong environments for 

writing, editing, and debugging code in HTML, CSS, and JavaScript. 

They also provide tools that improve productivity and make it easy to 

create complex and dynamic websites through syntax highlighting and 

code completion. It is imperative to make sure that it is functioning 

with optimal performance and testing and optimization tools are 

supposed to help with this. Google Page Speed Insights and GT 

metrix evaluate the speed of websites and offer recommendations for 

improvements, while Browser Stack enables cross-browser and cross-

device for compatibility and responsiveness testing. All these tools are 

vital for detecting and solving performance bottlenecks, ensuring a 

smooth user experience. Simply put, modern web designer toolkit 

consists of a multifaceted arsenal; each tool adds to the ability to 

create visually stunning and functionally sound websites. It 

encompasses everything from wire framing and prototyping to user 

testing and analysis, enabling designers to quickly iterate on their 

ideas and bring them to life. Selecting an appropriate tool for every 

phase of the design process is essential in creating an effective and 

captivating online platform. Each category plays a significant role in 

the design process, from crafting wireframes to establish the 

fundamental structure to refining visual aspects with graphic design 

software and confirming performance through testing tools. This full 

Fig 5.1 Types of Web Development 

[Source: https://talvasoft.com] 



  

124 
MATS Centre for Distance and Online Education, MATS University 

 

Notes suite of tools allows designers to construct the digital framework 

governing our behavior online. 

 

Graphic design tools are the foundation of visual communication in 

the digital world, including web design. Provides the creators the 

power to shape and polish the elements that take the identity of a 

website. These are not tools for just nibbling on the edges of visual 

design, they are central to the crafting of the logos, the images and UI 

elements that direct user engagement and user experience. These 

applications offer a digital canvas where designers can play with 

different elements and ideas, bringing abstract thoughts into a visual 

reality, helping to ensure that the website's aesthetic communicates 

whatever it aims to express. Texturing, palette manipulation, 

controlling shape makes it possible to craft compelling graphics that 

catch and hold user attention while improving overall aesthetic of the 

website. There are many graphic design tools and their capabilities 

and popularity are really high. Adobe Photoshop: A giant in the field 

of image design, Photoshop provides tools for editing and enhancing 

raster images, including high-end retouching, compositing, and 

technical imagery. In contrast, Adobe Illustrator shines in vector 

graphics, offering a stage for creating logos, icons, and illustrations 

that remain clear at any size. Figma has gained popularity recently, 

allowing for real-time collaboration on interface design and 

prototyping. It enables various designers to collaborate on a project at 

the same time, encouraging smooth communication and iteration. 

Figma's prototyping feature, lets you test the layout, UI & UX even 

before you start coding. Because there is such diversity in the needs 

that web designers have, there are a whole range of tools creating 

truly great and functional websites. What makes these graphic design 

tools so strong is their feature-rich offerings that allow granular 

control over any visual piece. Designers can tweak color values, bend 

shapes to their will and play with a range of textures, effects and 

filters. With such control, it is easier to produce graphics tailored to 

the specific sensibilities of the prospective audience. As a web 

designer, the ability to create visually stimulating components is of 

vital importance since it has a direct impact on the user’s workflow 

and perception. This ensures that the visual identity doesn't just look 

good, but also communicates the brand's message and improves the 



 

125 
 

Notes user experience as a whole. It this ability to create top notch graphics, 

that makes graphic design tools a necessity in today web design. 

Wireframing and prototyping tools master the most important part of 

web design where we plan and visualize what we want. These digital 

tools now replace the pencil and paper that architects use to prepare 

drafts of their designs, enabling a designer to plot a basic blueprint 

and the operations of a website, prior to getting into the nitty-gritty of 

coding. Mainly these tools are used for creating visual aids that 

illustrate how the site will look, how it will be function and how the 

navigation will work. Wireframing (typically with Balsamiq) is about 

creating low-fidelity sketches. These mock-ups are deliberately 

simple and focus on the layout of components like headers, footers, 

content areas, and nav menus. The purpose here is to work out the 

bare-bones layout of the site, without laying out too much visual 

detail such as color palette or typography. Because you have data 

rules, you know what to navigate around, but also where to focus for 

initial work to start on. 

At its core, prototyping tools (e.g. Sketch, In Vision) build on this 

wire framing, turning static layouts into clickable mockups. These 

mockups actually simulate the user experience by allowing designers 

to create clickable elements, transitions, and animations. This 

interactivity offers an authentic preview of user experience on the 

website, facilitating early testing and adjustments. Designers can play 

with various user flows, spot potential usability problems, and tweak 

them, all before diving deep into dev work. This iteration is critical to 

getting the final product designed in an intuitive and user-friendly 

way. These prototypes help designers to predict user actions while 

developing to serve the best possible experience.  Smart wireframing 

and prototyping tool is one of the powerful tools in the web design 

toolkit. They help the design team to easily articulate abstract 

concepts into tangible digital experiences and foster clear 

communication & collaboration between designers, developers, and 

stakeholders. visual design with the structure and the functionality of 

the website and makes sure that the design is aligned with user needs 

and business goals. With the ability to test and adjust designs before 

development, the risk of costly mistakes is mitigated, and the end 

product is guaranteed to provide a seamless and engaging user 

experience. But in the end, these instruments are one of the drivers to 



  

126 
MATS Centre for Distance and Online Education, MATS University 

 

Notes provide nice looking, powerful and user-cantered websites; hence 

contribute to the success of the digital project. Web builders have 

changed the industry websites design due to which Websites are now 

available to anyone without level coding or even any coding problem. 

These tools offer an easy-to-use platform that enables anyone to 

develop an entirely distinct website without requiring any technical 

proficiency. Website builders are such due to their drag-and-drop 

editors, which turn the complicated task of building web pages into an 

intuitive process. Users create the layout of the elements text boxes, 

images, buttons, etc. using visuals only, without even a single line of 

code. When the design interface is visual, users can concentrate on 

their website's look and feel and content instead of bending 

themselves into a pretzel trying to nail down the syntax of a code. 

Examples include popular sites like Wix, Word Press. Dotcom, Web 

flow and other powerful web development tools provide myriad 

options to suit everything from plain people blogs to fully-fledged e-

commerce sites. In addition, a wealth of pre-designed templates and 

customizable themes offered by website builders make the design 

process even more seamless. And, provides a free starting point for 

users to create a professional-looking website layout. Users can easily 

change colors with a few clicks, along with fonts, elements of design, 

etc., to match their brand or design preference. Moreover, the ability 

to utilize plugins and extensions adds even more functionality to these 

platforms, allowing individuals and businesses to integrate such things 

as contact forms, social media feeds, and e-commerce functionality. 

With a modular structure, sites can be highly customized and tailored 

to specific needs. Drag and drop feature: The drag-and-drop 

functionality of on-page editors helps you to integrate all the features 

without entering into coding, making it time-efficient and saving 

efforts to build a polyfunctional website. 

 

Essentially, website builders have democratized web design for non-

technical users. They enable individuals to build and maintain their 

presence on the internet with easy-to-use tools and information. C. 

Ease of use has led to the democratization of web design and has 

nurtured a culture of digital creativity, enabling individuals or small 

businesses to craft a professional online presence without requiring a 

lot of technical knowhow. Website builders are an invaluable tool for 
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Notes creating a compelling and functional website, thanks to the ease of 

use coupled with customizable templates and powerful plugins. This 

democratization encourages most of the population to engage with the 

digital realm, increasing countless people’s digital fluency and 

visibility. These highly sophisticated software tools become the main 

working environment for professional web designers and developers 

in building complex digital structures for modern web pages. Unlike 

visual website builders that target beginner users, code editors 

Structure granular control over layout and allow for detailed editing 

of the code that drives web functionality. These tools are designed not 

only as text editing applications but as powerful environments armed 

with functionalities and tools to help make the coding process more 

efficient, productive, less error-prone and so on. Syntax highlighting, 

which visually differentiates elements of code (e.g., commands, 

nouns, verbs, etc.), is one of its central features. Another important 

feature, code completion predicts and suggests code while writing is 

still going on, decreasing typing and syntax errors. Additionally, 

built-in debugging tools help developers pinpoint and fix errors 

quickly, which leads to smoother operation of their websites. One of 

the determining factors in the efficaciousness of code editors is their 

flexibility to work with a multitude of programming tongues. Within 

web development, that includes essential technologies like HTML to 

define the structure of web pages, CSS to set how they are visually 

presented, and JavaScript to create interactivity and dynamic content. 

But code editors also support server-side languages such as Python, 

PHP, and Ruby, which are essential for creating complex web 

applications and managing server-side logic. This makes it possible 

for developers to all use the same tooling, the same platform, and 

even the same command line regardless of the fact that different 

technologies might be used in the same project. This versatility is 

exemplified by tools such as Visual Studio Code, Sublime Text, and 

Brackets, which provide strong support for various languages using 

extensions and plugins. Such ability is essential for building dynamic 

and sophisticated websites that require immense level of control and 

customization. 

 

The fundamental significance of code editors in the context of web 

development can be attributed to their capability, which allows 
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Notes developers to retain tremendous power over the act of creation. Just as 

visual tools hide most of the code behind the curtain, code editors 

strip away the curtain to expose the inner workings enabling fine-

tuning and tweaks. Such precision is required not only to develop 

websites to functional specifications but also to tight performance 

requirements. For developers building bespoke web apps or complex 

ecommerce platforms, the need to customize every facet of the 

codebase is essential. Additionally, code editors are commonly 

integrated with version control systems (VCS) such as Git, making 

collaboration easier and ensuring that all changes made to the code are 

monitored and documented efficiently. These tools are really the 

backbone of any serious web developer, and allow them to turn 

creative visions into robust and efficient digital realities. 

While web design must aim towards aesthetics, performance should 

never take a back seat. This is where testing and optimization tools 

are essential. These tools look beyond assessing the aesthetics of a 

website but into the deeper mechanics of what constitutes a user 

experience. A website's performance matters most in the end it 

should load quickly, work correctly, and are responsive on all devices. 

And present all important aspects performance metrics or the likes so 

designers can dig through this critical information. Examples include 

Google Page Speed Insights and GTmetrix, which provide detailed 

assessments of your site's speed, identify problem areas, and offer 

practical advice for improvement. These tools break down what 

factors affect load times—things like image sizes, how clean the code 

is, how fast the server responds, and allow designers to optimize their 

creations for the highest efficiency. Additionally, the way websites 

are rendered varies from device to browser in the modern digital 

world. This means that websites need to work well and look good 

across this wide array of possibilities, in order to achieve a consistent 

and pleasant user experience. This is where Browser Stack comes into 

play, helping designers verify the functionality of their websites 

across various browsers and devices, mirroring actual usage 

conditions. By conducting a thorough testing process this way, 

compatibility issues are detected and dealt with, ensuring that 

websites perform as expected on every platform users choose to 

utilize. Since this is such an essential piece of web experience, using 

these different testing and optimizations tools you can find and fix 
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Notes performance bottlenecks before they become problems for your users 

when browsing your site. Collecting important data allows for more 

focused and effective user interaction subsequent to this. Now, all of 

this serves as the digital toolkit for the modern-day web designer, a 

fact inkle of how technology has transformed over the years. You 

think you can design beautiful websites now, wait till you learn how 

to optimize them for speed and compatibility. With the said 

knowledge of various web designing tools, web designers are able 

enough to create beautiful and functional experiences for the web. 

These tools allow designers to bring their visions to life, effectively 

further building the internet and keeping it alive and growing. Such 

powerful tools emplace an identity of pipelines and share caches 

between design and technical prowess between web designers in the 

digital world and define their role primarily in shaping digital 

experiences. 

Choosing the Right Web Designing Tool 

Selecting the right tool depends on the project requirements, technical 

skills, and design goals. Beginners may prefer drag-and-drop website 

builders, while advanced users might opt for code editors and graphic 

design software. A combination of tools is often used to achieve the 

best results.  

5.1.2 Admin and General Site Settings 

Admin and general site settings play a crucial role in the efficient 

management and functionality of a website. These settings help 

administrators configure and control various aspects of the website, 

ensuring smooth operation, security, and user experience. 

1. Understanding Admin Settings 

Admin settings are the backbone of website management, allowing 

site owners or administrators to regulate user roles, permissions, 

security measures, and system updates. These settings typically 

include: 

• User Management: Administrators can add, remove, or 

modify user roles such as editors, contributors, and 

moderators. They can also reset passwords and manage access 

levels. 

• Security Settings: Admins can enforce strong password 

policies, enable two-factor authentication (2FA), and set up 

firewall protections to safeguard the website. 
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Notes • Content Moderation: This includes setting up approval 

workflows for user-generated content, moderating comments, 

and filtering spam. 

• Backup and Restore: Websites often include an option for 

automated or manual backups, allowing quick restoration in 

case of failures or cyberattacks. 

• Performance Optimization: Admin settings may include 

options for caching, database management, and file 

compression to enhance website speed and efficiency. 

2. General Site Settings 

General site settings define the overall structure and appearance of the 

website, ensuring a cohesive user experience. Some key aspects 

include: 

• Site Title and Description: These are crucial for branding and 

SEO, as they define how the website appears on search 

engines and browser tabs. 

• Time zone and Language Settings: Setting the correct time 

zone ensures that scheduled posts, user activity logs, and other 

time-sensitive elements function correctly. Language settings 

enable multilingual support if needed. 

• Theme and Layout Customization: Many content 

management systems (CMS) allow administrators to modify 

themes, fonts, and colors to align with brand identity. 

• SEO and Metadata Configurations: General settings often 

include options to integrate keywords, meta descriptions, and 

sitemaps, improving search engine visibility. 

• Email and Notification Preferences: Admins can configure 

email alerts for new user registrations, security issues, and 

system updates. 

3. Importance of Proper Configuration 

Optimizing admin and general settings enhances website security, user 

experience, and operational efficiency. Misconfigured settings may 

lead to security vulnerabilities, poor website performance, or 

accessibility issues. 

5.1.3 Writing Posts and Formatting Text 

Writing posts and formatting text effectively is essential for clear 

communication, whether in blogs, social media, academic writing, or 
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Notes professional documents. Proper formatting enhances readability, 

engages the audience, and improves the overall impact of the content. 

 

1. Writing a Post: Key Considerations 

When writing a post, it is crucial to consider the purpose, audience, 

and platform. The tone, structure, and length vary based on whether 

the post is for a blog, a business update, or a social media platform. 

• Purpose: Define the objective—whether to inform, persuade, 

entertain, or engage. 

• Audience: Tailor the language and style based on the target 

readers. 

• Clarity and Conciseness: Use simple language and break 

down complex ideas into digestible chunks. 

• Engagement: Use storytelling, examples, and questions to 

captivate readers. 

2. Structure of a Well-Written Post 

A well-organized post typically follows a structured format: 

• Title: A compelling and informative title grabs attention. 

• Introduction: Provides an overview of the topic and sets the 

context. 

• Body: The main content is divided into paragraphs, bullet 

points, or numbered lists for better readability. 

• Conclusion: Summarizes the key points and may include a 

call to action. 

3. Importance of Formatting Text 

Formatting enhances the visual appeal and readability of a post. Well-

structured text helps readers navigate through the content effortlessly. 

• Headings and Subheadings: Organizing content with 

headings improves clarity. 

• Bold and Italics: Important terms or key points can be 

highlighted using bold or italics. 

• Bullet Points and Numbered Lists: These help in breaking 

down information into easy-to-read sections. 

• Paragraph Spacing: Avoid long blocks of text by using short 

paragraphs with proper spacing. 

• Hyperlinks: Adding links to relevant sources provides 

additional information and credibility. 

4. Formatting in Different Platforms 
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Notes Different platforms have specific formatting options: 

• MS Word & Google Docs: Offer extensive formatting tools 

such as font styles, sizes, alignment, and spacing. 

• Social Media (Facebook, Twitter, and LinkedIn): Limited 

formatting; use spacing, emojis, and hashtags effectively. 

• Blogs & Websites: Support HTML or built-in editors for 

customizing text appearance. 
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Notes Unit 5.2: Publishing a Post 

 

5.2.1 Publishing a Post : Adding Digital Content 

Publishing a post is the process of making written content available to 

an audience on a digital or print platform. Whether it’s a blog post, a 

social media update, or an article on a website, publishing involves 

several key steps, including content creation, editing, formatting, and 

distribution. Below is a detailed explanation of the publishing process. 

1. Planning and Research 

Before publishing a post, it is essential to plan the content. This 

includes selecting a relevant topic, understanding the target audience, 

and conducting research to gather accurate information. A well-

researched post adds credibility and ensures the content is valuable to 

readers. 

2. Writing the Content 

Once the topic is decided, the next step is drafting the post. It should 

be structured with a clear introduction, informative body paragraphs, 

and a strong conclusion. The writing style should match the platform 

formal for academic or business content and conversational for social 

media or blogs. 

3. Editing and Proofreading 

Editing is a crucial step before publishing. It involves checking 

grammar, spelling, and sentence structure to ensure clarity and 

professionalism. Proofreading helps eliminate typos and 

inconsistencies. Many writers use tools like Grammarly or Microsoft 

Word’s spell check for assistance. 

4. Formatting the Post 

Proper formatting enhances readability. Key formatting elements 

include using subheadings, bullet points, bold or italicized text for 

emphasis, and images or infographics to support the content. On 

websites and blogs, SEO (Search Engine Optimization) techniques 

like keyword placement and meta descriptions improve visibility. 

5. Adding Multimedia 

Images, videos, and links to relevant sources enhance engagement. A 

well-placed image can break long blocks of text and make the post 

visually appealing. Videos or GIFs can add an interactive element, 

especially on social media platforms. 
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Notes 6. Publishing on the Chosen Platform 

Once the content is ready, it is uploaded to the selected platform, 

whether it’s a personal blog, a news website, or social media. On 

blogging platforms like WordPress or Medium, users can schedule 

posts for later publication or publish them immediately. 

7. Promoting the Post 

Publishing is just the first step; promotion ensures the content reaches 

a wider audience. Sharing posts on social media, sending newsletters, 

or using SEO strategies helps attract readers and increase engagement. 

8. Monitoring and Updating 

After publishing, tracking the post’s performance through analytics 

tools can help improve future content. Regular updates keep posts 

relevant, especially for evergreen topics. By following these steps, one 

can successfully publish a post that is engaging, well-structured, and 

impactful. 
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Notes Unit 5.3: Inserting Content to Webpage 

 

5.3.1 Adding Images, Managing Media Library, and Creating 

Links 

In modern digital content creation, images and media elements play a 

crucial role in enhancing readability and engagement. Whether using a 

content management system (CMS) like WordPress or document 

editors like Microsoft Word, understanding how to add images, 

manage media libraries, and create links is essential. 

Adding Images 

 

Adding images to a document or website improves its visual appeal 

and helps convey information effectively. In MS Word, users can 

insert images by navigating to Insert > Pictures, where they can select 

images from their computer, stock images, or online sources. Once 

inserted, images can be resized, repositioned, and formatted using the 

Picture Tools menu. In a CMS like WordPress, images can be added to 

posts and pages through the Add Media button. Users can upload files 

from their local storage or choose existing images from the media 

library. Proper image formatting includes adding alt text for 

accessibility and compressing images to enhance page load speed. 

Managing Media Library 

The media library is a centralized repository that stores all uploaded 

images, videos, and documents. In WordPress, the media library 

Fig 5.2 Adding Images 

[Source: https://www.vskill.com] 
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Notes allows users to organize, edit, and delete media files efficiently. It 

provides features like: 

• Filtering by type and date – Users can quickly find specific 

media files. 

• Editing images – Basic adjustments such as cropping, 

rotating, and resizing can be done directly in the media library. 

• Deleting or replacing files – Users can manage their 

storage space by removing unnecessary media or replacing 

outdated content. 

Proper organization of the media library prevents clutter and ensures 

faster content management. Best practices include naming files 

descriptively, categorizing them into folders (if supported by the 

platform), and optimizing file sizes to maintain performance. 

Creating Links 

Hyperlinks are essential for navigation, allowing users to connect 

different pages, documents, or external resources. In MS Word, users 

can insert links by selecting the text or image, right-clicking, and 

choosing Hyperlink. They can then enter the desired URL or link to a 

document within the file. In Word Press and other CMS platforms, 

creating links involves selecting the text, clicking the Insert Link 

button, and pasting the URL. Links can be set to open in a new tab or 

remain in the same window for better user experience. Using 

hyperlinks strategically improves content connectivity, enhances SEO, 

and provides readers with additional resources for better 

understanding. 

Summary: 

The final module integrates knowledge into practical web designing 

applications. It starts with an introduction to web designing tools, 

covering platforms and software that simplify the creation of 

websites. Learners are guided on publishing posts and managing 

website content, which is essential in blogging and content-driven 

platforms. They also learn about inserting content on webpages, 

including text, images, links, and media, ensuring that web pages are 

interactive and user-friendly. The module highlights aspects of design 

aesthetics, usability, and accessibility. By the end, learners gain an 

understanding of how to design, develop, and publish engaging web 

pages for both personal and professional use. 

MCQs: 
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Notes 1. What is web designing? 

a) Writing books for the web 

b) Creating visually appealing and functional websites 

c) Designing software applications 

d) Coding in Java 

Ans b) 

2. Which tool is commonly used for web designing? 

a) Photoshop 

b) Microsoft Excel 

c) WordPress 

d) VLC Media Player 

Ans c) 

3. What does CMS stand for in web designing? 

a) Content Managing Software 

b) Content Management System 

c) Creative Media System 

d) Computer Management System 

Ans b) 

4. What is the function of an admin panel in a website? 

a) To manage website settings and content 

b) To browse the internet 

c) To edit images 

d) To store emails 

  Ans a) 

5. How do you insert an image into a web page? 

a) Using the <img> tag 

b) By writing JavaScript 

c) Using the <pic> tag 

d) None of the above 

Ans a) 

6. Which file format is most commonly used for images on 

websites? 

a) .jpg 

b) .mp3 

c) .docx 

d) .exe 

Anc a) 
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Notes 7. What is the purpose of hyperlinks in web pages? 

a) To play music 

b) To link one webpage to another 

c) To change text color 

d) To delete images 

Ans b) 

8. What is a media library in website management? 

a) A collection of music files 

b) A place where website images, videos, and files are stored 

c) A backup system for emails 

d) A software tool for coding 

Ans b) 

9. What is the function of the publish button in a CMS? 

a) Deletes a webpage 

b) Makes the webpage live on the internet 

c) Moves the page to drafts 

d) Formats text 

Ans b) 

10. Which tag is used to create a hyperlink in HTML? 

a) <link> 

b) <a> 

c) <h> 

d) <url> 

Ans b) 

Short Questions: 

1. What is web designing? 

2. Name some popular web designing tools. 

3. What is a Content Management System (CMS)? 

4. What is the purpose of an admin panel in web designing? 

5. How do you insert an image into a website? 

6. Explain how hyperlinks work in HTML. 

7. What is the function of the media library in website 

management? 

8. How can you format text in a web post? 

9. What are the steps to publish a post on a website? 

10. What is the difference between draft and published posts? 

Long Questions: 



 

139 
 

Notes 1. Explain the importance of web designing in today's digital 

world. 

2. Discuss different web designing tools and their uses. 

3. What is the role of CMS in web development? Explain with 

examples. 

4. Explain the process of writing and formatting text in a web 

post. 

5. What is an admin panel? Discuss its importance in website 

management. 

6. How do you insert and manage images in a website? Explain 

with examples. 

7. Describe the process of adding and formatting hyperlinks in a 

webpage. 

8. What are the steps to publish a post in a CMS platform like 

WordPress? 

9. Explain the significance of the media library and how it is 

used in website management. 

10. Discuss the process of creating an interactive and user-friendly 

website. 
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Notes Glossary List 

Absolute Reference: Fixed reference using $ (e.g., =$A$1+$B$1). 

Alignment: The positioning of text (left, right, center, justified). 

Body Section: Defines the visible content of the webpage. 

Bullets & Numbering: Tools to organize lists with symbols or 

numbers. 

Cell Reference: The address of a cell (e.g., A2, B5). 

Chart/Graph: A visual representation of numerical data. 

Content Management System (CMS): Software (like 

WordPress) used to manage website content. 

CSS Selector: A pattern used to target HTML elements for 

styling. 

DOCTYPE Declaration: A statement (<!DOCTYPE html>) that 

tells the browser the HTML version used. 

Domain Name: The address of a website (e.g., 

www.example.com). 

External CSS: CSS stored in a separate .css file linked to 

HTML. 

Form Elements: Input fields, text areas, radio buttons, 

checkboxes, and submit buttons. 

Function: A predefined formula like SUM(), AVERAGE(), or IF(). 

Handouts: Printed version of slides distributed to the audience. 

Head Section: Contains metadata, title, and linked resources (like 

CSS/JS). 

Header & Footer: Sections at the top/bottom of a page for 

repeating information (page numbers, date, etc.). 

Hyperlink (<a>): A clickable text/image that redirects to another 

page. 

Image Tag (<img>): Embeds images into a webpage. 

Indentation: Space at the beginning of a paragraph to improve 

readability. 

Inline CSS: CSS written directly inside an HTML element. 

Lists: Ordered (<ol>) or unordered (<ul>) collections of items. 
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Notes Media Embedding: Adding videos, audio, or interactive elements 

into webpages. 

Multimedia: Use of audio, video, and interactive elements in 

presentations. 

Navigation Menu: Links that help users move between 

sections/pages. 

Notes Pane: Section for adding speaker notes to slides. 

Pivot Table: A tool that summarizes and analyzes large data sets. 

Placeholder: A container in a slide layout for text, images, or 

other content. 

Publishing Workflow: Steps from drafting content to making it 

live. 

Range: A selection of cells (e.g., A1:A10). 

Relative Reference: Adjusts automatically when copied (e.g., 

=A1+B1). 

Responsive Design: Websites that adapt to different screen sizes 

(desktop, mobile). 

SEO (Search Engine Optimization): Techniques to make 

websites rank higher in search engines. 

Slide Master: The main template that controls overall design 

consistency. 

Table: A structured arrangement of rows and columns to organize 

data. 

Template: A pre-designed document structure used as a starting 

point. 

Theme: A collection of colors, fonts, and effects applied to slides. 

Track Changes: A feature that highlights edits for collaborative 

reviewing. 

Transition: The effect applied when moving from one slide to the 

next. 

Watermark: A faint background image or text in documents for 

branding/security. 

Web Hosting: A service that stores and delivers websites to users 

online. 



  

142 
MATS Centre for Distance and Online Education, MATS University 

 

Notes Widget/Plugin: Add-on tools to extend website functionality. 

Wireframe: A rough sketch or layout plan of a webpage. 

Workbook: A file containing multiple worksheets. 

Worksheet: A single page within a spreadsheet file. 
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